I was looking for a way to switch to gdm3 from lightdm, when I found this answer. So I tried to apply it, and entered sudo dpkg-reconfigure gdm3, then a selection screen appeared with 2 options: gdm3 and lightdm. It was the same screen that appeared during the installation of GNOME (using sudo apt install ubuntu-gnome-desktop && gnome-shell). I chose gdm3 then pressed Enter, then I got this error:

gdm.service is not active, cannot reload.
invoke-rc.d: initscript gdm3, action "reload" failed.

Any ideas?


It turns out that it just required a reboot to work. But I still want to know the meaning of that error I got. Does anyone have any explanation?

5 Answers 5


re: sudo dpkg-reconfigure gdm3 error message.

Just reboot and you should be running gdm3.

The error that you're receiving just means that gdm3 wasn't already running, so it couldn't reload it.

  • do you know what that error means though?
    – Tooniis
    Commented Jul 24, 2017 at 20:04
  • 2
    It just means that gdm3 wasn't already running, so it couldn't reload it. Kind of a bogus error.
    – heynnema
    Commented Jul 24, 2017 at 20:05
  • 1
    this didn't work for me
    – salouri
    Commented Dec 29, 2018 at 19:16
  • 1
    @trust_words please start a new question and we'll try and help you.
    – heynnema
    Commented Dec 29, 2018 at 20:46

Use this sudo dpkg-reconfigure lightdm in place of sudo dpkg-reconfigure gdm3 this and then choose gdm3.

  • 1
    Can you please explain how would that make any difference? When either of them is used, options are shown to switch default DM.
    – Kulfy
    Commented Jun 24, 2019 at 19:14
  • 2
    But there is something different between both of them as I tried it work, When I work on lightdm I use dpkg-reconfigure lightdm and on gdm use gdm in place of lightdm and it works without any error Commented Jul 3, 2019 at 8:38
  • 3
    I agree, you should specify the one you are using at the moment. Don't know why but it's always worked for me. Commented Mar 12, 2020 at 23:32
  • This should be the accepted answer! Commented Sep 11, 2021 at 4:34

Works for my WSL2 Ubuntu Desktop install - thanks:-

sudo systemctl start gdm3.service    
sudo dpkg-reconfigure gdm3
  • Awesome as it does not need reboot
    – M at
    Commented Dec 25, 2021 at 21:30

I actually found a hack! You just need to type this in terminal:

sudo apt-get install lightdm

Then you will get the option to choose your display manager where you can choose GDM instead of LightDM.

Worked for me, hope it works for you too.

  • This does not answer the question after the Update but it may help future users.
    – VidathD
    Commented Jun 19, 2020 at 5:08
sudo systemctl start gdm3.service    
sudo dpkg-reconfigure gdm3

So manually start gdm3, then reconfigure it and it stays working, even after a reboot.

(I know, weird, I'll update the answer if I work out what causes this)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .