2

I am worried I may have bricked my computer. I altered one character in the /user/share/X11/xkb/symbols/keypad to add a ] where there shouldn't be. The result is that all keyboard input does not work on my computer, even the on screen keyboard. The only thing I can do is login to guest user by clicking because no typing is necessary. How can I change this file from guest user using only copy and paste and guest permissions in terminal?

I have copied a whole list of commands into a txt file and have been copying and pasting them in to terminal, but I don't have the proper permissions.

What I wanted to do was "sudo cp -f" the correct version of the keypad xkb file but even with the sudo password I cannot do that from guest.

1

You are lucky that you obviously know what broke your keyboard setting. To repair:

  • log in to that machines with an administrator account via an SSH session (only if you run an SSH server) to then start an editor as root to undo erroneous settings.

or

  • repair the erroneous file from booting a live session with an Ubuntu installation USB/CD (choose "Try out Ubuntu") where you can mount your local drive for editing.
  • i cannot thank you enough. the second option worked like a charm!!! – user717067 Jul 24 '17 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy