12

Recently I decided to switch to Firefox and found a really annoying problem. The I-Beam appears next to non-editable texts if I click next to them. This breaks the Home, End and PgUp / PgDn keys.

Here's a sample

How can I prevent this?

  • 1
    And next time, do not blindly click OK in popups. Firefox actually told you what was going to happen when F7 was accidentally pressed. – dotancohen Jul 24 '17 at 17:41
  • @dotancohen Did it? Do all versions of Firefox issue a dialog box? I use caret browsing from time to time on all the machines where I use Firefox, so maybe it's just been a long time since I was prompted. But this seems like an unwarranted assumption, especially considering that people often share an account on their Ubuntu system or allow friends, family members, coworkers, or IT professionals to use their browser from time to time, and considering it is very easy to accidentally "click" OK if an unexpected popup comes up while you are typing (because pressing the spacebar usually does it). – Eliah Kagan Jul 24 '17 at 17:54
  • I probably just misclicked Enter. – dat tutbrus Jul 25 '17 at 3:37
  • @EliahKagan: I'm not familiar with OS-X, but the Linux and Windows Firefoxen do pop up a dialogue, and have since at least the sane-versioning days. I completely agree with the sentiment about the space bar "clicking" the dialogue away being problematic, I've seen that happen enough times in enough applications. However, users blindly clicking OK is a common enough issue that I'm comfortable mentioning it here, if not for the OP then for masses of people who will later read this thread. – dotancohen Jul 25 '17 at 4:45
22

Press F7.

This is called caret browsing. It is a Firefox feature that lets you move through and select text with your keyboard. F7 toggles it, so if you ever want to use this feature you can press F7 to turn it on, then again to turn it off.

(It is most likely that you had pressed F7 by accident to turn it on this time.)


Another way to turn caret browsing on and off is to go to Preferences > Advanced and check/uncheck the box labeled Always use the cursor keys to navigate within pages (under Accessibility).

Screenshot of Preferences, Advanced, Accessibility, Always use the cursor keys to navigate within pages

But F7 is easier.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.