0

For the past 2 days I've been struggling with trying to get a decent connection and speed of my WiFi. The Wireless speed on the Windows OS runs perfectly fine.

I've created a dual-boot on my laptop just to try Ubuntu and get the feel of it since I'm losing the feel for Windows now. However, after I installed Ubuntu I found out that my WiFi speed is REALLY slow.

I checked different posts what might be causing this but couldn't come to a solution of my problem.

Wireless Info: https://paste.ubuntu.com/25158086/

Dmesg: https://paste.ubuntu.com/25158097/

0

From https://dfspspirit.wordpress.com/2015/06/08/wifi-connection-slow-and-unstable-on-intel-wireless-7260-and-linux/

The solution is the usual way of passing options to drivers in linux, you edit the config file and add the option you want. The driver for the Intel 7260 is called iwlwifi, and the config file is at /etc/modprobe.d/iwlwifi.conf under debian-based distros.

To disable 11n, append the following line to that file:

options iwlwifi 11n_disable=1

Then reboot your laptop, and you should have way better wifi.

| improve this answer | |
  • This is not a good idea with 7260. – Pilot6 Jul 24 '17 at 18:19
  • @Pilot6 - Can you explain why not and/or offer a better solution ? So unlike you to leave such a cryptic comment. – Panther Jul 24 '17 at 18:21
  • Well. I am using the 7260 and know it quite well. The 11n_dsable solutions are good for older Intel adapters. Disabling 802.11n won't definitely make it faster ;-) – Pilot6 Jul 24 '17 at 18:24
  • According to the OP - "This worked perfectly fine! Thank you!" so transcribed the WP blog here. I dont have the chip to test. – Panther Jul 24 '17 at 18:26
  • I can suggest to change the wireless channel form 10 to 1. There are strong APs at 10 and 11. – Pilot6 Jul 24 '17 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.