0

I have 2 graphic cards (gtx 1070) attached to the mainboard. lspci detects both cards

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1b81 (rev a1)
02:00.0 VGA compatible controller: NVIDIA Corporation Device 1b81 (rev a1)

But there's only one "Device" Section in the xorg.conf file, and there's no graphic output on the card that X Server doesn't detect. I then tried adding the second graphic card manually, by adding Screen 1 “FakeScreen1” to Section "ServerLayout" and

Section "Monitor"
    Identifier     “FakeMonitor1”
    VendorName     “Dummy”
    ModelName      “Dummy”
EndSection

Section "Device"
    Identifier     "Device1”
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "Coolbits" "31"
    BusID          "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier     “FakeScreen1”
    Device         "Device1”
    Monitor        “FakeMonitor1”
    DefaultDepth    24
    Option         "Coolbits" "31"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

to the end of the xorg.conf file. Ubuntu fails to boot after that, with this error on blank screen: error

I then overwrite the tweaked xorg.conf with the default-back-up-xorg.conf and ubuntu reverts back to previous state with 2nd gpu not detected by X.

Where did I get it wrong? What can I do to make X recognized the second gpu?

  • Run the graphical tool - askubuntu.com/questions/302518/… – Panther Jul 23 '17 at 15:55
  • @bodhi.zazen both nvidia-smi and NVIDIA X Server settings detects both cards, but the xorg.conf created by nvidia-xconfig shows only one card :|. There's no graphic output on the second card that Xserver doesn't detect :( I forgot to add that to the question, adding now – Nhu Thai Sanh Nguyen Jul 24 '17 at 1:44
  • On the graphical tool, run as root. Then get it setup the way you want, and save the settings to xorg.conf. Do not merge with previous. If that does not work I would have to google for an xorg.conf – Panther Jul 24 '17 at 2:39
0

I was able to fix it. The problem was that I edited the xorg.conf file with Apple's Seirra TextEdit which converted all my " to and which aren't pure ascii characters. Therefore, X couldn't read the config file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.