1

I apologise if this has been asked before, but I cannot find this exact bug mentioned anywhere.

GIMP simply refuses to load on my instance of Ubuntu 16.04. I've tried removing/purging it, then running

sudo apt clean
sudo apt-get update
sudo apt-get upgrade

and finally running BleachBit for good measure, before reinstalling... but it still simply refuses to load. I've tried installing it directly from the command line, as well as through the Ubuntu Software Centre.

The frustrating thing is that I'm not getting any error message; when I run

sudo gimp --verbose

I get the output

INIT: gimp_load_config
Parsing '/home/$user$/.config/GIMP/2.9/unitrc'
Parsing '/etc/gimp/2.0/gimprc'
Parsing '/home/$user$/.config/GIMP/2.9/gimprc'

and it will simply hang there. I've been patient and left it running for an hour (!) and it doesn't make any progress.

Thanks in advance for your help.

Edit 1: the output of ls -lAR /home/your_user | grep ' root ' is:

drwx------  3 root  root   4096 Jul 21 13:57 .dbus
drwx------  2 root  root   4096 Jul 21 13:58 .gvfs
ls: cannot open directory '/home/aaron/.cache/dconf'drwx------ 2 root  root   4096 Jul 22 13:04 dconf
: Permission denied
ls: cannot open directory '/home/aaron/.dbus': Permission denied
-rw-rw-r-- 1 root  root    4164032 Jul 21 12:41 libmwservices.so
ls: cannot open directory '/home/aaron/.gvfs': Permission denied
-rw------- 1 root  root    212 Jul 21 22:11 root
-rw-r--r-- 1 root  root  32768 Jul 21 22:11 root-d56cc46b.log
lrwxrwxrwx  1 aaron aaron     18 Jul 20 22:35 root -> /home/aaron/.steam`
  • Uninstalling does not clean your configuration files. Please rename said file to something else then try again. – Andrea Lazzarotto Jul 23 '17 at 14:14
  • Thanks for the quick response. I uninstalled gimp, renamed the "gimprc" file to "gimprc-old" and reinstalled. Unfortunately the problem persists. – Aaron Jul 23 '17 at 14:19
  • 2
    Why are you running gimp with sudo? that's a recipe for messed-up personal config file ownership - and all the associated problems that brings – steeldriver Jul 23 '17 at 14:30
  • I'm quite new to all this, as you can probably tell. I get the same issues if I simply run {gimp}. I was under the - clearly mistaken - impression that using {sudo} would reduce the chance of running into file permission problems. Do you have any recommendations or advice? Should I purge everything, reinstall, and make sure not to run using {sudo}? – Aaron Jul 23 '17 at 14:37
  • Quick update - I tried purging gimp, deleting the entire .config/GIMP folder, reinstalling gimp, and then running it without sudo. The problem bravely persists despite all my efforts – Aaron Jul 23 '17 at 14:45
2

Well you have so many potential problems it is hard to know where to start.

First, and perhaps most important, you should not be running gimp as root. More likely then not running as a regular user will fix that.

You really should not be running much of anything as root. Installing packages and updating is about all you need to run as root.

Second, you really need to understand what reinstalling will and will not do. Specifically, removing/purging/reinstalling will NOT touch any configuration files in your home directory.

Third, reinstalling rarely fixes anything. The only exceptions would be if you edited system files or very rare system files somehow became corrupt.

Fourth, why are you running bleachbit ? This is not windows, the system rarely if ever needs to be cleaned, I have never seen a performance problem solved by bleachbit, and if you do not understand what you are doing, bleachbit can do a lot of damage, at least the last time I looked, worse if you are running it as root as you are with gimp.

If you feel you need to "clean" your home directory you can delete ~/.cache , clean the trash, and delete thumbnails.

So my first piece of advice is that you stop your bad behavior before you break more then gimp.

Second, run gimp as your regular user and post any errors.

You can try:

mv ~/.config/GIMP ~/.config/GIMP.bak

Notice how we back up rather then delete ? Probably a good habit for you. If this fixes the problem you can then clean up by rm ~/.config/GIMP.bak If you need things from the backup you can always restore part or all of what you moved.

But from your bad behavior you may need to fix ownership and permission problems in your home directory. what files / directories are currently owned as root ?

ls -lAR | grep root
  • Thanks for this - I'm very new to Linux, so I haven't developed good behaviours yet. We all have to start somewhere! But thanks for the advice, I appreciate you taking the time to help a newbie. Backing up the ./config/GIMP folder doesn't solve the issue. The output of ls -IAR | grep root is very long, too long to post here, but seems to primarily consist of files/folders which contain the string "root". An example of a line in output is: -r--r--r-- 1 aaron aaron 431 Aug 16 2013 construct_root.m As an aside, all my data is backed up, so 'radical solutions' are an option... – Aaron Jul 23 '17 at 15:11
  • Once again, thank you very much. New user runs into the exact same problem. I have added the output of ls -lAR /home/your_user | grep ' root ' to my original question above – Aaron Jul 23 '17 at 15:29
  • When I run sudo chown -R aaron:aaron ~aaron/.dbus ~aaron/root && sudo rm -rf ~aaron/.cache I get the error "chown: cannot access '/home/aaron/root': No such file or directory" I tried sudo chown -R aaron:aaron ~aaron/.dbus /root && sudo rm -rf ~aaron/.cache but it did not fix the problem – Aaron Jul 23 '17 at 15:54
  • Now you need to run sudo chown -R root:root /root and sudo chown -R aaron:aaron ~aaron/.steam . Log out and back in, run sudo apt-get updat && sudo apt-get dist-upgrade and re-run gimp. Post any errors. – Panther Jul 23 '17 at 15:58
  • I followed all of your instructions, but the problem persists and there are still no error messages. I installed gimp by running the command sudo apt-get install gimp. I am running Ubuntu 16.04 – Aaron Jul 23 '17 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.