2

Am running Ubuntu 16.04 and have been having irritating problem with boot.

Often - but not always - when I start up, the boot pauses for 90 seconds with the message "[***] A start job is running for dev-mapper...", switching to list all devices currently listed in /etc/fstab. After 90 seconds boot continues but drops into single-user mode.

Once this happens, I can then boot successfully by selecting recovery mode, and then selecting "Resume normal boot".

After much headscratching I think I have traced the problem to an issue with fsck. Boot runs normal reliably when I set fs_passno 0 for my root filesystem (a 256GB SSD formatted ext4). I tried this after booting into a live USB and attempting fsck on the root filesystem and received the message:

/dev/sdd1 has unsupported feature(s): metadata_csum
e2fsck: Get a newer version of e2fsck!

When I downloaded a new version (from E2fsprogs) fsck ran correctly.

So my tentative thinking is that the version of fsck running at boot is incompatible with my root file system.

Any suggestions on how to fix this? I'd rather not just disable fsck permanently, but at the moment it seems to be the only solution.

3
  • 1
    This has never happened for me on my 16.04. Interesting issue.
    – user595510
    Jul 23, 2017 at 10:54
  • 1
    What version is it (apt-cache policy e2fsprogs)? I notice there's a comment in the 1.43.4-2 changelog "Re-enable metadata_csum for Debian (which was accidentally disabled for 1.43.4-1)" Jul 23, 2017 at 12:42
  • Output of apt-cache policy e2fsprogs: 2fsprogs: Installed: 1.43.4-2 Candidate: 1.43.4-2 Version table *** 1.43.4-2 500 500 http://au.archive.ubuntu.com/ubuntu zesty/main amd64 Packages 100 /var/lib/dpkg/status Could it be that the initrd image is still using the version of fsck provided on the install image of 16.04, even though e2fsprogs has since been updated? The live USB I used was downloaded fresh yesterday, so presumably is still using 1.43.4-1.
    – Dylan Rowe
    Jul 24, 2017 at 10:14

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.