1

I use an Asus E202S notebook.

I can't change my brightness using Fn key combinations.

When I use xbacklight, it returns

no outputs have backlight properties

In my /sys/class/backlight directory I have two symbolic links:

asus-nb-wmi
intel-backlight

I tried some suggestion with xrandr and changing pci but to no avail.

I have created an xorg.conf in /etc/X11:

Section "Device" 
Identifier "Card0" 
Driver  "intel" 
Option  "Backlight"  "intel_backlight" 
EndSection

Yet still no change.

I am a complete newbie, so please help accordingly.

1
1

I had a similar problem so I made this script.

clone this repo and paste the script into the /bin directory. then make the script executable by using the following script.

sudo chmod +x /bin/backlight.sh

here is the repository for the script:

git clone https://github.com/el-beth/backlight.sh.git

in your case, change the third line of the script from:

BRIGHTNESS_DIRECTORY=$(cd /sys/class/backlight/* && pwd);

to

BRIGHTNESS_DIRECTORY=$(cd /sys/class/backlight/intel-backlight && pwd);

for more info read the README.md file in the cloned backlight.sh directory.

1
  • the third line is not BRIGHTNESS_DIRECTORY=$(cd /sys/class/backlight/* && pwd); i found it to be MAX_BRIGHTNESS=$(cat /sys/class/backlight/*/max_brightness); – Mahir Jul 23 '17 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.