0

So, basically, from one day to another, my external HDD is not being auto mount in Ubuntu 16.04

I did not make any change in the OS The only change I've made it's that I bought a new cable for the external HDD cause the previous one was loosy.

This is the output of fdisk -l

I reckon that the sdb1 it's for the external disk

Disk /dev/sda: 149,1 GiB, 160041885696 bytes, 312581808 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disklabel type: dos Disk identifier: 0x8194093d

Device Boot Start End Sectors Size Id Type /dev/sda1 * 2048 304390143 304388096 145,1G 83 Linux /dev/sda2 304392190 312580095 8187906 3,9G 5 Extended /dev/sda5 304392192 312580095 8187904 3,9G 82 Linux swap / Solaris

Disk /dev/sdb: 931,5 GiB, 1000170586112 bytes, 1953458176 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disklabel type: dos Disk identifier: 0x00023f15 Device Boot Start End Sectors Size Id Type /dev/sdb1 * 2048 1953458175 1953456128 931,5G 7 HPFS/NTFS/exFAT

any help please?

I've already try in all 3 usb ports The External HDD light blinks makes "a work like" sound Reboot laptop, but nothing

EDIT1

lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 149,1G  0 disk 
├─sda1   8:1    0 145,1G  0 part /
├─sda2   8:2    0     1K  0 part 
└─sda5   8:5    0   3,9G  0 part [SWAP]
sdb      8:16   0 931,5G  0 disk 
└─sdb1   8:17   0 931,5G  0 part 
sr0     11:0    1  1024M  0 rom  

sudo mount -t exFAT /dev/sdb1 /mnt
mount: unknown filesystem type 'exFAT'

sudo mount -t ntfs /dev/sdb1 /mnt/
ntfs_mst_post_read_fixup_warn: magic: 0x44414142  size: 1024   
usa_ofs:       8572  usa_count: 29550: Invalid argument
Record 0 has no FILE magic (0x44414142)
Failed to load $MFT: Input/output error
Failed to mount '/dev/sdb1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

**unplugged disk**
ls /dev/ | grep sd
sda
sda1
sda2
sda5


**plugged disk**

ls /dev/ | grep sd
sda
sda1
sda2
sda5
sdb
sdb1

I've also connected to a Windows computer. It detects correctly the USB Driver, but on "My Computer" the disk appears with no info at all. I've run chkdisk /f x: (where x is the disk unit) and the test said it fail basically. And reboot Windows twice. No change at all.

  • Exactly what errors did chkdsk show? It sounds like a corrupt file system, or a hardware problem. – heynnema Jul 23 '17 at 2:21
  • @heynnema Windows cannot repair master file table. I've tried chkdsk /f and /r but the same result. – MrThompson Jul 23 '17 at 15:28
  • If you start the Disks application in Ubuntu, and go to the "hamburger" icon, and select "SMART Data & Tests", review the data, and run the tests. – heynnema Jul 23 '17 at 19:00
  • That option is unavailable for that disk, is greyed out. – MrThompson Jul 23 '17 at 20:49
  • Did you select the disk in the left pane before trying to select SMART? When you say you replaced the USB cable because it was "loosy", what do you mean? What is light blinks makes "a work like" sound... can you describe the sound better? Did this external disk used to work in Ubuntu? Do you have backups of the data? – heynnema Jul 23 '17 at 20:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.