3

I got to eliminate almost every sign of a console from bootup to lightdm (only the quick appearance of a cursor from grub still annoys me) but shutdown is a mess: at least an "fsck clean" message appears, but sometimes more, right before plymouth kicks in.

I'd like it if:

  • I could make the messages not appear, either by suppressing them (more difficult, since the fsck message is there from before lightdm... I can make it go away THEN but not on shutdown) or by making the font black on the console, which I don't know how to do on shutdown; or
  • Plymouth kicked in earlier.

I tried this solution: How to hide console messages on shutdown? - but this is very old and we don't have an rc.conf anymore.

In this case: Console text appears on shutdown - there is a problem with nvidia but I have an integrated Intel, so it has nothing to do with that. Also people do not seem to care about the text - I KNOW it doesn't mean trouble, I just want to get rid of it.

In this case: Console shows on shutdown/logout - Comments to the answer just reassure it's normal behaviour.

Thanks in advance!

1

In Ubuntu 18.04 Server LTS, edit

/etc/sysctl.d/10-console-messages.conf and set

kernel.printk = 0 4 1 7

Actually the first value (0) is what you need. According to https://elinux.org/Debugging_by_printing, setting that first number to 0 means only "Emergency messages" are shown ("system is about to crash or is unstable").

1
  • Thanks for the answer! I forgot I had asked this; meanwhile I replaced grub with booting with efi and it apparently solved the problem - but since this seems to be the way to go I'll mark it as the correct answer. – Peterson Silva Jun 8 '18 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.