I have a Samsung N220 modified with a Pixel QI screen. For those of you who don't know Pixel Qi, they make normal LCDs that once the backlight is turned completely off they act as (kind of) e-ink screens. That means, no light but still readable. I chose this computer because it even has a hotkey (Fn+F5) to turn the backlight off. It worked perfectly on windows, so it's not a hardware issue. It was too slow so I installed lubuntu and tried to use it like that, but it didn't work. When I used the "brightness decrease" hotkeys, it made it darker, but it still had some backlight. Then I tried all the solutions I read here, like:

echo 0 | sudo tee -a /sys/devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight/brightness

The command works, but 0 doesn't turn the screen backlight off, it just makes it darker but again it still has light. There was an alternative version of this I read somewhere here, which was wirting the number this gives you:

cat /sys/class/backlight/intel_backlight/brightness

And then dividing the actual number by 6 and writing it on the code,like this (2070 is the number already divided by 6)

sudo su -c "echo 2070 >/sys/class/backlight/intel_backlight/brightness"

I tried it (changing the location with the folder I had the brightness settings in my computer, but, just like the others, it didn't turn the backlight off.

I tried then with a different solution,

xbacklight -set 0

The same thing happened, it was darker but it still had light.

After that, I tried a couple of different of similar solutions, installed a Brightness controller which only changed the gamma settings and tried the same things in a lot of different distributions (Xubuntu, Ubuntu, Lubuntu, Slacko Puppy, Vector linux, Absolute linux, and a couple more I don't remember) I had the same results.

I also tried changing 20-intel.conf with one I downloaded that was supposed to fix the brightness control not working for Ubuntu 14.04 & Linux Mint 17. It worked on another computer and it turned the screen backlight off with a hotkey (I think it was Fn+F6 or Ctrl+F6), but not with the Samsung N220-

Finally, I tried a Wifislax distribution. The first command that I had already tried on every other distribution works perfectly with this one, turning the backlight completely off:

echo 0 | sudo tee -a /sys/devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight/brightness

But the problem is that this distro doesn't fit my needs. As far as I know it's made to crack wifi networks and I want this computer to write a novel in Open Office (it has to be that one because of compatibility issues with my main computer), to write sheet music in Musescore (this one I could sacrifice it and write them on my main computer), to use dropbox (since I write on both computers and I want it to update the same files without having a hundred versions of them and not knowing which one is the right one) and finally to have a internet browser (so I can check wordreference, wikipedia and other sources for research purposes). I need to turn off the backlight because I'm really sensitive to flickering lights and it gives me headaches and anxiety and also because I prefer to work outside under the sunlight.

If someone knows a way to fix this or a distribution that fits my needs with similar characteristics to wifislax, please let me know. If the solution works in ubuntu, taht would be way better, as I liked how it worked on my computer.

Thanks a lot in advance and sorry for the huge description.

  • Have you tried -1? Ping me @fabby after you've tried this. – Fabby Jul 22 '17 at 20:48
  • Hi fabby, thanks a lot for your help. unfortunately, that doesn't work since the parameter wont go beyond 0 – javipax Jul 23 '17 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.