I recently erased and reinstalled Ubuntu GNOME 17.04 on my laptop (Because I encrypted my home folder with the first installation and wasn't able to remove the encryption). The first time, everything worked perfectly. The second time, things were working well for a while. But today, I installed screenfetch and ran it thrice, after which, I switched off my laptop. I switched it on five hours later, and I wasn't able to start the terminal by pressing Ctrl+Alt+T. I tried opening it from the list of applications, but it just showed Terminal loading on the top bar and closed. I read online that screenfetch can cause this problem, but when I used screenfetch with the first installation, nothing like this happened. I tried all of those locale settings solutions, but none worked. For now, I'm only able to use XTerm, and I'm only able to run GNOME Terminal by typing the command dbus-launch gnome-terminal in XTerm. Is there any way to fix this? Because I really like GNOME Terminal and I don't want to have to reinstall again.

SIDE NOTE: I made a temporary user account, and tried running GNOME Terminal in that account. And it worked as it was supposed to.

UPDATE: When I try starting terminal from Xterm by typing gnome-terminal, it gives the following error:

Error constructing proxy server for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

UPDATE 2: I ran the command dbus-update-activation-environment --all in Xterm, and Terminal started working again. But after rebooting, Terminal stopped working again. Even if i type the command again.

UPDATE 3: Typing the following command in Xterm gets GNOME Terminal working properly again, but it requires me to type this every time I reboot.

sudo localedef -v -c -i en_US -f UTF-8 en_US.UTF-8


Open gedit and see if it shows a transparent editing window. This may be a similar symptom as your terminal symptom.

Delete this file in your home directory and see if terminal works as before...

cd # change directory to home
rm -i .xinputrc # delete file with prompt

The file will recreate itself when required.

Update #1:

cd # change directory to home
cd .gconf/apps # change directory
mv gnome-terminal gnome-terminal.HOLD # rename folder

Now retry to start gnome-terminal.

  • Gedit was fine when I tried it. Also, when I executed the command you gave, it said that the file .xinputrc doesn't exist. – Caramello Jul 23 '17 at 7:14
  • Have you edited any of the .bash* or .profile files in your home directory? – heynnema Jul 23 '17 at 13:34
  • I'll update my answer. – heynnema Jul 23 '17 at 13:40
  • I actually gave up and reinstalled Ubuntu GNOME, because I had lots of college work, and I wasn't able to find a solution. But, I'll accept your answer anyway. Thank you so much :) – Caramello Jul 24 '17 at 13:52

you need to add dbus-update-activation-environment --systemd --all into ~/.xinitrc

or download scripts from followings


  • I ran dbus-update-activation-environment --systemd --all on the command line and then I could start gnome-terminal. I did not have a ~/.xinitrc, so I created it and entered dbus-update-activation-environment --systemd --all into it; then I restarted my session and now everything works fine. (Earlier I found that I also needed to add export XAUTHORITY=~/.Xauthority to my .bashrc file.) FWIW, I'm using ubuntu 18.04 and xfce4 (with tigervncserver). Thanks Eli! – Generic Ratzlaugh Jul 21 '20 at 15:00

I clobbered gnome-terminal while using xemacs over ssh; I wish I could be more specific. However, the only way to repair gnome-terminal was to backup my user account with tar and recreate my account. I wasted many hours trying to fix it before giving up and using brute force.

  • 2
    I don't thin kit's necessary to delete the whole profile. – davidbaumann Mar 31 '18 at 19:24
  • It's better than what OP did as he/she reinstalled the entire OS. – Fabby Apr 1 '18 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.