0

I recently updated my kernel version to 4.8 on Ubuntu 16.04 and when I type sudo apt-get update in the terminal, it shows the following error:

enter image description here

Error! The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which does not match this kernel/arch. This indicates that it should not be built.

1
  • 1
    Can you copy/paste the text, instead of posting links to images. – mikewhatever Jul 22 '17 at 7:33
3

Whenever we add a development or testing PPA to our system we may be faced with compatibility issues on upgrading.

See: What are PPAs and how do I use them?

In your case kernel modules from audio drivers added through the ppa:ubuntu-audio-dev/ppa do not match the kernel version that is going to be installed. As audio drivers are regularly updated in newer kernel version you may no longer need this ppa. After removal you will be able to update your kernel.

In case you had installed several drivers you may have to restore the default packages by running ppa-purge.

See: How can PPAs be removed?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.