0

Okay, so i've recently moved apartments and had to switch to comcast (don't know if this is relevant) and I set up my server to find that i have no internet despite being connected via ethernet. I've looked up tons of reports and have tried a few solutions to no avail.

I'm relatively new to ubuntu so excuse me but it tells me that eth0 and wlan0 are not found. There is a nameserver in the /etc/network/interfaces but i don't know if i was supposed to edit anything when i moved. if i ping 8.8.8.8 it tells me that the Destination Host is unreachable. ifconfig shows lo and p10p1 and says it is ethernet but can't do much.

Thank you so much anyone who can help.

interface readout imgur.com/a/AgcpV

  • Are you sure that your ethernet is live? have you tried with another device? And if it is, have you ensured that you can reach your router (usually type 10.0.0.1 or 192.168.1.1 into your web browser, although it varies by router) – brndn2k Jul 21 '17 at 20:51
  • Please edit your question to add the result of this terminal command: cat /etc/network/interfaces Also, what is the IP address of any other device on the same network; ipads, phones, etc.? – chili555 Jul 21 '17 at 21:05
  • brndn2k, 10.0.0.1 got me into my router, i've tried this before and no matter what it tells me i have the wrong log in info... called comcast and they were clueless and said they would get back to me. – MRuss Jul 21 '17 at 21:11
  • chili555 adding in one sec – MRuss Jul 21 '17 at 21:12
  • IIRC Router details are admin/password. See here xfinity.com/support/internet/… – brndn2k Jul 21 '17 at 21:26
1

I suggest that you edit your /etc/network/interfaces file to read something like this:

auto lo
iface lo inet loopback

auto p10p1
iface p10p1 inet static
address 10.0.0.101
netmask 255.255.255.0
gateway 10.0.0.1
dns-nameservers 8.8.8.8 10.0.0.1

Reboot and check to see if you are connected:

ping -c3 10.0.0.1
ping -c3 8.8.8.8
ping -c3 www.ubuntu.com

If you get ping returns from all three, you are all set.

0

your server has a static IP address in a subnet of 192.168.x.y - while your router has an address in the address range of 10.a.b.c - if your router does not have a second ip address in the same subnet as your home server (and I doubt that), they won't be able to communicate anything between each other.

change the static IP on your homeserver either to the same subnet as your comcast router or let it get its IP via DHCP.

  • He was able to access the router. Wouldn't that qualify as able to communicate something? – brndn2k Jul 21 '17 at 21:28
  • Well oddly enough, i can communicate to the server through ssh (albeit much slower than before) and samba, pinging 10.0.0.1 works. Trying to ping or reach anything doesn't work – MRuss Jul 21 '17 at 21:39
  • It sounds as if he was accessing router as well as server from a third system, this may have both up ranges configured due to some odd circumstances. But according to tcp/ip standards and when those are implemented properly, it is totally impossible that router and server communicate when in different subnets without another router to route those packages between the subnets. Avahi may confide – Phillip -Zyan K Lee- Stockmann Jul 22 '17 at 6:47
  • An odd circumstances may be due to avahi/mdns/etc auto-configuring detected subnets. – Phillip -Zyan K Lee- Stockmann Jul 22 '17 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.