0

I just got a HughesNet internet satellite installed and I had to go to work when the tech was installing it so he was only able to get the WiFi to work. So now I don't want to use WiFi. I want to be able to run an ethernet cable directly from the Modem to my switch which I have 3 Linux workstations on it. I was using (with my previous modem) these settings in /etc/network/interfaces:

auto eth0
iface eth0 inet static
address 192.168.0.15
network 192.168.0.0
netmask 255.255.255.0
broadcast 192.168.0.255
metric 0
dns-nameservers 192.168.0.1

but now I look at the LAN settings for the modem:

IP address: 192.168.42.1
IP Subnet: 255.255.255.0

IP Address Poll:
192.168.42.100
192.168.42.149

I don't really understand the Network section of System Settings and I tried calling the help desk at Hughesnet and they are totally useless.

I can access the internet over the WiFi using my laptop which is very slow. So I would like to use the ethernet cable to at least my main Linux desktop. I'm using the interfaces file from one of the other workstations which the address is 192.168.0.15.

  • You have to change you ip from 192.168.0.x to 192.168.42.x , change the 3rd digit, keep the first, second, and 4th digit the same. – Panther Jul 21 '17 at 17:53
  • I did that plus, I also changed the network, netmask, broadcast, gateway and dns-nameservers to xx.xx.42.xx – SpaceCowboy Jul 21 '17 at 18:25
  • (sorry - hit return by mistake) and I also found a screen in the modem setup called LAN DHCP where you can specify the mac address and ip address of the workstations. I can also ping 192.168.42.1 from the workstation. – SpaceCowboy Jul 21 '17 at 18:29
  • try specifying ip address of your workstations. You may need to then restart networking. 192.168.42.1 is your gateway so should be working. If not, what problem do you have ? Could be a dns problem ..... – Panther Jul 21 '17 at 18:31
  • my /etc/network/interfaces file looks like this: auto eth0; iface eth0 inet static;address 192.168.42.15;network 192.168.42.0;netmask 255.255.255.0;broadcast 192.168.42.255;gateway 192.168.42.1;metric 0;dns-nameservers 192.168.42.1 – SpaceCowboy Jul 21 '17 at 18:56
0

From the discussion this problem was solved by:

  1. changing to the correct subnet, so address 192.168.0.15 was changed to address 192.168.42.15 so address 192.168.42.x changing the third "0" to "42" .

  2. Setting dns to 8.8.8.8

    dns-nameservers 8.8.8.8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.