0

On Lubuntu 16.04, within the last week the nm-applet indicator disappeared from the taskbar even tho LXTask shows it running, and the wifi connection works as usual. The missing indicator is a new behavior- it has run fine for ~6 months since OS install. At first look, nm-applet was not in LXSession core applications and when I clicked Reload, the indicator came back on the panel for a couple hours, then it disappeared again. I went back to LXSession, reloaded again (no change); then manually added it to startup appl's + reboot - no joy.

After reading here, I edited /home/*****/.config/autostart/nm-applet.desktop . NotShowIn=KDE;GNOME; also had LXDE;. I removed LXDE;, saved, + reboot - no change.

In terminal $ nm-applet returns:

** (nm-applet:#####): WARNING **: Error retrieving accessibility bus 
address: org.freedesktop.DBus.Error.ServiceUnknown: The name 
org.a11y.Bus was not provided by any .service files

##### is a 4 or 5 digit number which gets higher when I do the command again.

$ sudo nm-applet returns the above, plus:

(nm-applet:#####): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: 
assertion 'window->update_and_descendants_freeze_count > 0' failed

I tried reinstalling lxpanel-indicator-applet-plugin. I've found posts suggesting installing other network monitor or indicator packages + have tried several, with no success. But the indicator worked fine for many months, LXTask shows nm-applet running, something removed nm-applet from LXSession, and added LXDE to NotShowIn in 'autostart/nm-applet.desktop`. These things suggest the answer is more likely to be fixing nm-applet, indicator, or environment, rather than adding something else. I have read there was a bug with nm-applet in 14.04 but that appears to be fixed a year or more ago.

Thanks.

1

3 things fixed this.

  1. This error:

** (nm-applet:#####): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files

... was fixed by installing at-spi2-core from Synaptic Package Manager.
Reference: https://github.com/NixOS/nixpkgs/issues/16327

  1. Then in /etc/xdg/autostart/nmapplet.desktop, I changed Exec=nm-applet to dbus-launch nm-applet.
    After manually restarting nm-applet in a terminal window with dbus-launch nm-applet, the wifi indicator applet appeared in the taskbar again. But it did not autostart after a reboot.

  2. So in Settings > Default Applications for LX Session, in the Autostart tab, I changed nm-applet to dbus-launch nm-applet.

Then the applet autostarted, and the indicator autostarted.

Reference for 2. and 3. : http://askubuntu.com/questions/592406/nm-applet-wifi-issues-on-lubuntu-14-04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.