1

I maintain two ThinkPad T420 laptops running Ubuntu 16.04 which have both started having overheating issues within the last few weeks. As both computers ran just great for many months before this, I am suspecting that the problem arrived with an update, but I can't say for sure.

Symptoms are:

  1. Overheating occurs only in Ubuntu, not in Windows 7.
  2. Overheating occurs only when connected to AC power. When removed from AC power, the temperature quickly drops to normal.
  3. Overheating occurs only when the computer is in at least moderate use. If it's left idle, the temperature stays normal.
  4. If all these conditions are met, the CPU temperature rises slowly over about an hour or so. The fan goes on and the CPU throttles but nothing succeeds in lowering the temperature. The temperature plateaus at around 95 degrees Celsius (according to psensor), the system slows to the point of unusability, and the computer is hot to the touch.
  5. CPU usage is normal. The fans seem to be fine. sudo top shows no unusual processes hogging the CPU.

What I tried:

  1. In the BIOS power tab, I changed two settings so that behavior under AC power is the same as under battery power.
  2. I installed thermald.
  3. I installed tlp, including the ThinkPad extras.

Results: Absolutely nothing. The problem is the same as ever.

Any ideas? Anyone else experiencing this?

Thanks!


Update -- problem solved:

Thank you Linrunner! I installed the updated version of TLP (1.0.1, via the PPA, rather than the one from Canonical). Then I set the new options: TLP_DEFAULT_MODE=BAT TLP_PERSISTENT_DEFAULT=1

And amazingly, since then, no more overheating. This is really more of a workaround rather than a solution, because it means forcing the computers to be in battery mode all the time, but I don't really notice any difference.

  • Does your laptop have a dedicated graphics card? Also, does the CPU run at the same frequency on AC as it does on battery? – Android Dev Jul 21 '17 at 15:20
  • TLP 1.0 has a new feature to easily implement BAT settings on AC. Configure TLP_DEFAULT_MODE=BAT; TLP_PERSISTENT_DEFAULT=1. – linrunner Jul 22 '17 at 12:00
  • ps. is your BIOS up to date? – linrunner Jul 22 '17 at 12:02

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.