0

After two days of surfing all forums possible and erasing alsa, pulseaudio and trying all the various rerouting and fixes I ask if you can help.

No way to get anything to play through the headphones!

On Mac Os no problem.

After trying this fix : cd /usr/share/pulseaudio/alsa-mixer/paths/ sudo cp analog-output-headphones.conf analog-output-headphones.bak sudo nano analog-output-headphones.conf

Look for the section called [Element Speaker] and change it so that it looks like this:

[Element Speaker] switch = on volume = ignore

I managed to get the sound to play very softly still through the speakers though.

Nothing through the headphones ever.

Any solutions? Thanks!

2

I get that it might no longer be relevant for you, but for other people coming running into this problem, I've had the same, took me days to figure out, but now I have got a very simple solutions that works well (I've reinstalled ubuntu so had to do it all again and kinda know the drill now):

This fix works for every 2011 iMac 27 and 21 inch alike

first open up terminal and enter:

sudo nano /etc/modprobe.d/alsa-base.conf

and add to the last line of the file:

options snd-hda-intel model=imac27_122

control+x - y to safe and then do the same in:

sudo nano /etc/modprobe.d/sound.conf

and again add to the last line:

options snd-hda-intel model=imac27_122

close and save it again, and reboot :)

if after this it still doesn't work type in terminal (don't undo your previous changes): alsamixer and unmute all the muted channels with "M"

0

Solved here: https://ubuntuforums.org/showthread.php?p=12043359

Solution for late 2011 iMmac:

There is no need to apply the patch above, because it is already there on your ubuntu, my procedure:

  1. By logic recognized which the lines in green mean the extra fix lines of the patch

  2. Using gksudo nautilus, then nautilus search feature, located the patch_cirrus.c and entered there with full write privileges (due to gksudo).

  3. Using gedit search feature discovered which one of the patch green lines was already there.

    After some additional thinking I noticed which one of the patch lines is close to other lines whose content are exactly used on /etc/modprobe.d/alsa-base.conf to solve such kind of problems. The alsa list of supported models for the cirrus codec is not updated yet to include that (I'm not sure if it will); no matter if you get the list from your own ubuntu or from the internet. There was no way to know this model existed without benzodiaz's help.

So open your terminal and:

  1. sudo gedit /etc/modprobe.d/alsa-base.conf

  2. add to end of the file "options snd-hda-intel model=imac27_122" (only the stuff inside the quotes), save and reboot.

This worked for me, the only fix from several and several others I tried. What a pleasant surprise, the fix was already there since this year January, it was only hidden.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.