4

I had installed the latest skype betta for ubuntu, it works but I hate the interface. Is there a way to downgrade it to the previous version?

  • No, there isn't. Even if you could install it it wouldn't connect. For further informations please contact Microsoft. – user692175 Jul 21 '17 at 2:21
8

2017-11-15 Update
It seems like 4.3 is now officially dead and the following instructions are no longer going to install a working version of skype. RIP Skype 4.3

Original Post

I have both the old (4.3) and new skype (5.4) (aka "skype for linux beta") installed and they both work. The new one tends to have issues with video so I still use the old one mainly. I believe the old way of installing should still work. Worked for me at least.

Edit after discovering skype no longer exists in ubuntu partner apt repo:

It seems that it is still available from a download link, may not be there for long though.

cd ~/Downloads
sudo dpkg --add-architecture i386
sudo apt-get update
wget download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo apt-get install -f

I just tried on a work pc running Ubuntu 16.04 and it installed fine. Ignore the errors that may appear after running sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb until you run sudo apt-get install -f (which fixes the dependency errors)

Credit goes to this question

  • Thanks. I have tried. Was too late probably. "Unable to locate package skype" in the end. – anatoly Jul 24 '17 at 1:07
  • 1
    Apologies, it seems it was removed from the ubuntu partners repo recently. I've updated my answer with an alternative, let me know if it works for you. – Ian Colwell Jul 26 '17 at 18:06
  • Tried that. At apt-get update received: – anatoly Jul 27 '17 at 20:50
  • Tried that. At apt-get update received: Failed to fetch cdrom://Ubuntu 16.04.2 LTS Xenial Xerus Tried then apt-cdrom -- didn't work for it couln't find the disk although I put it in. The system mounts it on /media/<my-user>/ and apt-cdrom is looking for it at /media/cdrom but I wasn't able to provide that -- not savvy enough. So, what is the way out now? – anatoly Jul 27 '17 at 21:06
  • 1
    I was running both 4.3 and 5.5.0.1, mainly because the new one does not store messages on sqlite. But It stopped working today... unfortunately... answers.microsoft.com/en-us/skype/forum/… – nephewtom Nov 15 '17 at 9:25
4

Microsoft owns Skype now..........and they say no, old versions won't work.

From the current Skype download web-page (July 20, 2017):

enter image description here

  • 1
    Yea, I knew. Hoped for a miracle :( – anatoly Jul 24 '17 at 1:04
  • @anatoly Actually, the website says what it says, but as far as now Skype 4.3 is still working. You can download it following IanColwell's answer and then install it via command-line or GUI. Or you can also download a multi-arch version here – TomCho Jul 28 '17 at 16:33
  • It stopped working today... unfortunately... – nephewtom Nov 15 '17 at 9:19
0

Download version 8 of Skype from here https://www.skype.com/en/get-skype/ One click was enough for recognizing OS and chipset. Installed automatically using Ubuntu Software

0

https://www.skype.com/en/get-skype/

Here you can download Skype for all the devices and platforms it comes for.

Skype 4.3 is dead it doesn't allow you to send messages to anyone. in the video call also you can hear but you'll get black screen instead of video. I faced this issue yesterday itself and had to install Skype 8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.