0

THE COMPUTER

  1. This is an assembled computer without any in-built Bluetooth and WiFi features. enter image description here

  2. Recently I changed my ISP for a high-speed internet connection. After installation of the fibre optic cable and its router, I connected the ethernet cable and switched on. The Ubuntu 16.04.2 LTS seamlessly configured automatically and connected to the internet in the first go, without any MAC or password for the router. The speed was 110 to 130 Mbps bothways.

PROBLEM

  1. On July 17, 2017 there was a prompt for available updates for Ubuntu. I installed that. When I re-started the computer next day, I found that ethernet is getting connected after a long time. But surprisingly, Firefox was unable to connect to any server.

  2. This is the Network Setting of my computer. enter image description here

  3. I tried different usual actions but to no avail. Below is the screen-shot of Ethernet Connection Information.

    enter image description here

SEARCH AND RESEARCH

  1. I have a Netgear N150 Wireless USB Adapter. I plugged it in and restarted the computer. Ubuntu recognised and configured it. Connected to the internet. Browsing was smooth. The speed is 50 Mbps both ways.

  2. Below is a screen-shot of the working WiFi Connection Information. enter image description here

  3. I tried many non-destructive suggestions from the forum, like updating Ubuntu, cleaning by ‘autoremove’, disabling the IPv6, manually entering IP and other numbers on IPv4 setting, browsing through Chrome, changing the ethernet cable and so on. BUT all in vein! It remained connected but no browsing is possible.

  4. I love Ubuntu but very novice when such problem surfaces. I noticed experts do ask output results to diagnose the problem. So to help my erudite friends to do so, and suggesting its remedy, I have pasted few output of commonly asked command line instructions below.

    ashoke@ashoke-desktop:~$ route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    

(Please note, nothing was shown as above. But the same command on WiFi mode displayed the following.) enter image description here ………………………….. enter image description here

enter image description here

enter image description here

Please help me. Best wishes to all.

As suggested following is the result removing the WiFi adapter.

ashoke@ashoke-desktop:~$ dmesg | grep -e e100 -e eno
[    0.711515] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
[    0.711997] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
[    0.712622] e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    0.881849] e1000e 0000:00:19.0 eth0: registered PHC clock
[    0.882325] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 00:22:4d:ab:ab:f0
[    0.882822] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[    0.883331] e1000e 0000:00:19.0 eth0: MAC: 11, PHY: 12, PBA No: FFFFFF-0FF
[    0.884452] e1000e 0000:00:19.0 eno1: renamed from eth0
[   78.836980] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[   79.043535] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[   82.629365] e1000e: eno1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[   82.629400] IPv6: ADDRCONF(NETDEV_CHANGE): eno1: link becomes ready
ashoke@ashoke-desktop:~$ 

A. I forgot to mention before, that I booted the computer through a live-USB device of the Ubuntu 16.04.2 LTS. It did not detect the ethernet. But manually it was possible to enable WiFi setting of the router.

B. @ chili555

Below is the report of the command you suggested. It is very long. So I paste few top lines.

ashoke@ashoke-desktop:~$ cat /var/log/syslog | grep -i dns
[    Jul 22 15:44:53 ashoke-desktop avahi-daemon[767]: Leaving mDNS multicast group on interface eno1.IPv6 with address fe80::aecf:d490:5a05:4046.
[    Jul 22 15:44:53 ashoke-desktop avahi-daemon[767]: Interface eno1.IPv6 no longer relevant for mDNS.
[    Jul 22 15:44:54 ashoke-desktop avahi-daemon[767]: Joining mDNS multicast group on interface eno1.IPv6 with address fe80::aecf:d490:5a05:4046.
[    Jul 22 15:44:54 ashoke-desktop avahi-daemon[767]: New relevant interface eno1.IPv6 for mDNS.
[    Jul 22 15:45:40 ashoke-desktop NetworkManager[857]: <info>  [1500718540.9292] policy: set 'Ethernet connection 1' (eno1) as default for IPv6 routing and DNS
[    Jul 22 16:02:34 ashoke-desktop avahi-daemon[767]: Leaving mDNS multicast group on interface eno1.IPv6 with address fe80::aecf:d490:5a05:4046.
[    Jul 22 16:02:34 ashoke-desktop avahi-daemon[767]: Interface eno1.IPv6 no longer relevant for mDNS.
[    Jul 22 16:03:23 ashoke-desktop avahi-daemon[767]: Joining mDNS multicast group on interface wlxc43dc7c58344.IPv6 with address fe80::ef46:e843:2ab1:898f.
[    Jul 22 16:03:23 ashoke-desktop avahi-daemon[767]: New relevant interface wlxc43dc7c58344.IPv6 for mDNS.
[    Jul 22 16:03:24 ashoke-desktop NetworkManager[857]: <info>  [1500719604.6555] policy: set 'JioFiber-RQwx4' (wlxc43dc7c58344) as default for IPv6 routing and DNS
******************
[    Jul 22 19:01:06 ashoke-desktop NetworkManager[870]: <info>  [1500730266.4789] dns-mgr: Writing DNS information to /sbin/resolvconf
[    Jul 22 19:01:06 ashoke-desktop dnsmasq[2557]: setting upstream servers from DBus
[    Jul 22 19:02:34 ashoke-desktop avahi-daemon[778]: Joining mDNS multicast group on interface eno1.IPv6 with address fe80::ceec:c245:d3a2:6680.
[    Jul 22 19:02:34 ashoke-desktop avahi-daemon[778]: New relevant interface eno1.IPv6 for mDNS.
[    Jul 22 19:03:22 ashoke-desktop NetworkManager[870]: <info>  [1500730402.9408] policy: set 'JobaB' (eno1) as default for IPv6 routing and DNS
ashoke@ashoke-desktop:~$ 
  • 2
    Boot an old kernel and see if the problem persists. What happens if you ping 8.8.8.8 ?ping -c4 8.8.8.8 – Panther Jul 20 '17 at 19:05
  • Please don't put screenshot of the terminal. Copy and paste the text into the question and then format the text as code by highlighting the pasted text and clicking on the { } icon above the edit window. – user68186 Jul 20 '17 at 19:12
  • 1
    Please detach the wireless and try to connect the ethernet. Next run: dmesg | grep -e e100 -e eno Edit your question to add the result. – chili555 Jul 20 '17 at 19:16
  • ashoke@ashoke-desktop:~$ ping -c4 8.8.8.8 connect: Network is unreachable ashoke@ashoke-desktop:~$ ping -c4 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_seq=1 ttl=57 time=26.7 ms 64 bytes from 8.8.8.8: icmp_seq=2 ttl=57 time=28.2 ms 64 bytes from 8.8.8.8: icmp_seq=3 ttl=57 time=27.3 ms 64 bytes from 8.8.8.8: icmp_seq=4 ttl=57 time=26.4 ms --- 8.8.8.8 ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 3004ms rtt min/avg/max/mdev = 26.421/27.217/28.259/0.723 ms ashoke@ashoke-desktop:~$ Sorry don't know how to format this. – bluepearlsky Jul 20 '17 at 19:20
  • It looks like the router is not assigning the Ethernet connection any IP4 address. Does the new ISP need a logon with password to access the Internet? Is the router setup correctly? – user68186 Jul 20 '17 at 19:39
0

Finally I have solved this problem.

I am neither a software expert, nor I am proficient to debug in Ubuntu. Therefore, I do not know, what went wrong, and how the problem has been solved.

Below are the steps I performed. My erudite friends shall be able to make out.

  1. Even after following numerous suggestions and trying many different ways to correct the problem, things were as it was in the first place: Ethernet connected, but no internet.

  2. I decided to replicate the situation that connected to the new router all by itself. For that I borrowed a Dell Inspiron laptop with Ubuntu 16.04.2 LTS.

  3. After switching ON, it showed the availability of existing WiFi connection. Switched off that.

  4. Along with the desktop, connected the Dell laptop to the router through ethernet on another slot. Switched it on. The laptop got hanged.

  5. Switched off the laptop. Removed the ehternet connection. Restarted again. Connected with the WiFi. Updated Ubuntu. It was about 500 Mb data. Disconnected it from WiFi. Switched off the laptop.

  6. Connected the laptop to the router again. Switched on. It got connected to the internet exactly as it took place in the first time with my desktop.

  7. Checked the ‘Connection Information’. It had all values of IPv4, which was missing in the desktop. I copied those and entered in the IPv4 setting of my desktop manually. I restarted my desktop and there it worked perfectly. Connected to the “Auto Ethernet” instantly and also the internet.

  8. On the desktop, changed the IPv4 setting from ‘Manual’ to ‘Automatic (DHCP)’. Shut down both desktop and laptop. Restarted again the desktop. It worked perfectly with ‘Automatic (DHCP)’ setting.

Here is the picture of the present ‘Connection Information’. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.