0

I am trying to create an adhoc network with following command in ubuntu 16.04:

sudo iwconfig wlan0 mode ad-hoc essid my-mesh-network ap 02:12:34:56:78:9A channel 1

however when I try to enable the interface, its giving me error

sudo ip link set up dev wlan0
output:
rtnetlink answers device or resource busy

This problem comes only when the interface mode is set to "Ad-Hoc"
In monitor mode or managed mode, this issue does not come.

Can you please tell me if this issue is due to the driver limitation or I am missing anything. Thanks in advance.

2

"rtnetlink answers device or resource busy"

I think it means exactly what it says. The device wlan0 is busy sending and recieving data to your router or access point, getting email, etc. I suggest that you tell it to stop:

sudo ifconfig wlan0 down

And try again:

sudo iwconfig wlan0 mode ad-hoc essid my-mesh-network ap 02:12:34:56:78:9A channel 1

If you have Network Manager running, you will probably need to stop it first:

sudo service network-manager stop
3
  • 1
    thanks @chili555, stopping the network-manager service helped. – Mahesh Jena Jul 21 '17 at 5:38
  • I cannot ifconfig wlan0 up after configure ad-hoc – King Stone Aug 5 '19 at 18:20
  • @KingStone Please start your own new question and include more details. – chili555 Aug 5 '19 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.