2

I've just come back from a short trip overseas (before which my drives were fine), and upon coming back and using my computer for the first time since, all of my main drives have become read-only.

I've tried changing permissions via the GUI, even after using sudo nautilus, and all it does is stay loading for a long period of time (I may try this overnight as well to see if that works).

I've also tried using chmod, and this was the result:

$ sudo chmod -Rf 755 /media/ben/Gateway
(nautilus:5870): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkComboBox'

(nautilus:5870): Gtk-CRITICAL **: gtk_combo_box_get_active_iter: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(nautilus:5870): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkComboBox'

(nautilus:5870): Gtk-CRITICAL **: gtk_combo_box_get_active_iter: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(nautilus:5870): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkComboBox'

(nautilus:5870): Gtk-CRITICAL **: gtk_combo_box_get_active_iter: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

How do I make them read/write?

5
  • 1
    Are you talking about external flash drives? Becoming read only for no apparent reason is usually the first sign of an upcoming failure. Do NOT mess with permissions if ypou don't know what you're doing (you don't, clearly, otherwise you wouldn't be doing "sudo nautilus"...).
    – user692175
    Jul 20, 2017 at 4:17
  • Use journalctl -b to see all system messages since last reboot.
    – waltinator
    Jul 20, 2017 at 8:18
  • No not an external flash drive, this is the internal hard drive on my laptop which was functioning fine up until I got back from my trip. Jul 20, 2017 at 23:45
  • I've had hard drives go read-only in Linux a few times, and it is usually, like MichaelBay said, bad hardware. I used to have a Linux desktop system where the IDE cables would develop a bad connection over time, and I had to unplug and replug them back in, every six months or so. Right now if I was you, I'd be all about backing up what you can of that drive just in case it's failing.
    – SunnyDaze
    Jul 21, 2017 at 0:48
  • 1
    So it turned out the reason it ended up up that way was because my Windows partition didn't shut down properly, leaving the drives on read-only due to hibernation mode. Just had to boot into Windows and shut down cleanly and now it's all working again. Jul 23, 2017 at 4:16

2 Answers 2

2

Turned out problem was due to Windows filesystem not being shut down properly (it had crashed and needed a hard reset before I left on my trip). All I had to do was boot into Windows and allow the computer to shut down naturally. The hibernate function had been preventing my drives from being accessible.

0
1

The cause of this issue is right. Chimichanga has given the proper steps to resolve it. But it didn't work for me. I found out a Windows' option that is causing the problem. For all who couldn't fix it from the answer by Mr. Chimichanga, Here's what I did to fix it:

  1. Reboot your device back to Windows 10
  2. Go to Power Options
  3. On the left tabbed panel, Choose what closing the lid does
  4. Give the permission to Change settings that are currently unavailable
  5. Uncheck Turn on fast startup

This is what causing the problem. Reboot to Linux again and this should fix your problem.

Also, I'm told to use the following command to fix the issue. I'm not really sure about it.

sudo ntfsfix /dev/drive_name
1
  • The power/lid has little to do with it. You just have to shutdown Windows completely (not hibernating) before booting Ubuntu, and indeed the "Fast startup" makes stopping Windows closer to an hibernation.
    – xenoid
    Jan 27, 2020 at 16:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .