2

I am trying to set up an Emby server with libraries located on different internal hard drives. Emby requires that I give the user it creates (emby) access to folders/files when I want it to read them. To that end, I have added emby to the group adm and given ownership of the files over to emby.

However, emby still refuses to see my inside my hard drives. It can see files located on my desktop (also owned by emby) but nothing in any external hard drive.

Is there some unique property external hard drive permissions have that I am overlooking?

  • Are the external drives NTFS formatted? – user692175 Jul 19 '17 at 23:45
  • @MichaelBay: When I do "sudo fdisk -l" I get that the hard drive that the OS is on is Type Linux, and both of the external hard drives are of type "Linux filesystem". – Rohit Saxena Jul 20 '17 at 1:21
  • If EXT3/4 then you may need to chown. – user692175 Jul 20 '17 at 1:23
  • @MichaelBay: Can you explain a little bit more? What do I chown? – Rohit Saxena Jul 20 '17 at 1:30
  • The entire partition, I guess. I don't know Emby and I don't know the requirements but perhaps you also need to mount it differently, using the fstab (or just open Disks, select partition, click the cog wheels menu and turn off, as counter-intuitive it may seem, then tick mount at the boot, and Disk will automatically add it to your fstab). emby.media/community/index.php?/topic/… – user692175 Jul 20 '17 at 1:41
1

You need to change owner and group of the folder/HDD using next command.

sudo chown user:user -R /path/to/hdd/folder/

Replace the: user:user with your own user and group that you need it.

The option -R it will change owner/group across files, folder and sub-folders

Replace the: /path/to/hdd/folder/ with path that you want to change owner/group (Permissions)

0

As user MichaelBay explains in the discussion of this question, the solution is to mount hard drives to your computer using fstab. A great explanation on how to do that is here. The most upvoted answer explains in great detail on how to do it. The only additional thing I would like to point out is if you have a hard time figuring out the location of your external hard drive's path (the 'dev/sdb..') it is located on the top right corner of gparted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.