My system is frequently, but intermittently locking up. I am unsure of what to do next to troubleshoot and/or whether I should report this as a bug. Advice would be appreciated. Note that my question is similar to one previously posted at radeon 0000:02:00.0: ring 0 stalled for more than 10492msec that has yet to be responded to.

My system intermittently locks up every few days. When that happens, the screen goes to black, then returns. At that point, the time on the clock indicates that the screen is frozen, but audio continues to play for 30 seconds to a minute. The keyboard and mouse do not affect what's being displayed, but I can Alt - SysRq - REISUB to restart.

Every time (6 crashes and counting), /var/log/kern.log indicates that

kernel: [353692.378886] radeon 0000:03:00.0: ring 0 stalled for more than 10280msec
kernel: [353692.378896] radeon 0000:03:00.0: GPU lockup (current fence id 0x00000000006e96e5 last fence id 0x00000000006e96e9 on ring 0)

just before the system locks. Different ring numbers are reported as stalling at different times.

I'm running 16.04 LTS. I have a Radeon HD graphics card.

:~$ lspci | grep VGA
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]

:~$ lspci -v -s 03:00.0
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd Cedar [Radeon HD 5000/6000/7350/8350 Series]
Flags: bus master, fast devsel, latency 0, IRQ 53
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at d3d20000 (64-bit, non-prefetchable) [size=128K]
I/O ports at 7000 [size=256]
Expansion ROM at d3d00000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: radeon
Kernel modules: radeon

In looking for solutions, I found an old bug report from 14.04 that is currently unassigned https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1409393.

[Edit:] Based on @MichaelBay 's suggestion, I ran the Checkbox graphics card tests and everything passed. I also I ran MemoryTest. No errors were found after 3 passes. Finally, I loaded Psensor to check the GPU temperatures, but there are no GPU readings.

  • Also, Based on information at help.ubuntu.com/community/BinaryDriverHowto/AMD and help.ubuntu.com/community/RadeonDriver I believe I am using the correct driver. – T. Lorax Jul 19 '17 at 17:58
  • Could be hardware. The driver is correct as in the only one you can use now. – user692175 Jul 20 '17 at 9:06
  • @MichaelBay - thanks for your suggestion. I ran a few hardware tests (see the edits in the original post), but if you have other suggestions about how I can test the hardware, please let me know. – T. Lorax Jul 20 '17 at 15:57

I'm suffering the same issue with 18.04 -- though admittedly I also found this issue with Arch Linux. I am starting to lean more towards hardware issues as well but am curious --

Did you ever find an answer to the problem?

  • 1
    Please vote up the question, or once you have enough reputation, add a bounty to the question to attract more attention to the question. Please see How to Answer for information about what a answer should look like. – ubashu May 25 at 3:37
  • 1
    @jardineworks - I had a separate issue with the fan on the video card, so I replaced it with non-Radeon hardware. I haven't had a problem since. Sorry I can't be of more help. – T. Lorax May 27 at 17:12
  • I wanted to note, for people looking for possible answers, that I am experiencing a similar problem with 18.04. And, I'm using the same CPU/motherboard from a 16.04 installation that did NOT have this issue. Screen locks to black or 1" square random pixel display. Have only exited that state with hard restart, or alt-sysreq--REISUB. Error messages (repeated) that might be related: "ACPI exception: could not find/resolve package element LNKA" (or B or C or D). Also getting a repeated spice virtio error - but that shouldn't be related. – Corvus B Jun 8 at 15:36
  • @T.Lorax: thanks for the update. I'm going to install a different GPU, maybe that will help. – Corvus B Jun 8 at 15:38
  • I'm not sure if this did it, and I am knocking on wood so hard right now that my neighbors are likely to complain :) ... but I added these settings to my grub boot flags quiet splash pci=nomsi radeon.dpm=0 dpm=0 .. and I haven't had an episode in more than a week now. I also switched back to using gnome in place of deepin desktop environment. When I was suffering the same issue on my Arch Linux install (previously) I was also running Deepin there -- so perhaps there is something in their code base that helps to manifest the issue. Regardless, I have 4 monitors going without issue now. – jardineworks Jun 12 at 13:39

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.