0

Running Windows 10 host with Ubuntu 17.04 guest in VirtualBox. VirtualBox host-only adapter established. I can ping guest (192.168.56.101) from host and ping host (192.168.56.1) from guest. Set up small NGINX demo as proxy listening on port 80 to spawn-fcgi on port 8000 to small C++ app. App responds to browser in guest requesting "localhost", but connection from browser on host is refused. ufw status is Inactive. Any ideas will be appreciated.

  • Did you go to the Network settings in VirtualBox and under the Advanced settings for the Adapter setup your Port Forwarding? – Terrance Jul 19 '17 at 16:53
  • All I wish to do is use the browser on my host to access the app on the guest, so I don't understand how port forwarding applies. – Mike L. Jul 19 '17 at 18:18
  • I have tried several configurations of port forwarding on the NAT connection without success. – Mike L. Jul 19 '17 at 18:19
  • Try setting it to Bridged so it is on the same network then. Everything should pass right through. – Terrance Jul 19 '17 at 18:22
  • That worked, confirming that everything in the guest is working, but now the guest app is accessible from all the other machines in my network. Not what I wanted. Is there any way to discover why http requests are being blocked on the host-only connection? – Mike L. Jul 19 '17 at 18:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.