3

I just installed the Ubuntu desktop environment (Unity), and now I'm getting Ubuntu style notifications in KDE. I don't really like this in Plasma, so how can I revert to the Kubuntu style notifications without uninstalling Unity?

Edit 0: This might have something to do with me switching my layout to lightdm, but I'm not certain.

Ubuntu Style Notifications

  • In my opinion, it's not the best thing to have both Unity and KDE together as you're seeing. Unity uses notify-osd. And because you installed Unity afterwards, notify-osd has taken over. I would just leave things as they are and when you next install a distro, make sure you install only the desktop environment you prefer and no other. – DK Bose Jul 23 '17 at 1:46
2

This happens because you have multiple notification services installed simultaneously.

Unfortunately, dbus doesn't seem to be able to intelligently select the appropriate notification service, so you will either need to disable one of the services (as detailed in this answer), or, if you want to keep both notify-osd and KDE's Plasma notification service installed and enabled, you will probably need to resort to a cumbersome workaround.

N.B: If you opt for the workaround you will need to adapt the shell script in Step 3 to

  1. detect when either KDE or Unity is running
  2. run /usr/bin/plasma_waitforname org.freedesktop.Notifications when KDE is running

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.