1

I'm using rsync to backup some files, but I realized that files with a .bak extension are not being copied.

sudo rsync -Cravp --delete /home/administrador/ArquivosAL/ /media/administrador/Seagate\ Expansion\ Drive/Backup

Some one knows why? How can I fix it? Thanks.

2

If you use -C option with rsync then it initializes an exclude list which contains .BAK files along with many others. You can use man rsync and look at what all is excluded by the -C option.

If you want to copy the .BAK files remove the above mentioned option from your command. Although, Note that this will mean that anything which was previously excluded due to this option will also be copied.

Thus your new command would be :

sudo rsync -ravp --delete /home/administrador/ArquivosAL/ /media/administrador/Seagate\ Expansion\ Drive/Backup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.