9

I used my Ubuntu Desktop yesterday as usual, but now I can't boot in because the screen keeps flickering to a black screen and a verbose boot screen where I see no failure or errors. I can ALT-F2 and see the login, but it stills flickers so I can't type correctly my password. I didn't install anything particular, I've searched a little and people talk about NVIDIA drivers, but I didn't install anything like this yesterday, what can I do?

Thanks for helping.

dpkg -l *nvidia* | grep ii returns

 nvidia-375               375.66-0ubuntu0.16.04.1
 nvidia-opencl-icd-375    375.66-0ubuntu0.16.04.1
 nvidia-prime             0.8.2
 nvidia-settings          361.42-0ubuntu1
10
  • is it the computer causing the problem or Ubuntu?
    – Camden
    Commented Jul 19, 2017 at 14:09
  • Ubuntu, I have a dual-boot, Windows works just fine.
    – Drakota
    Commented Jul 19, 2017 at 14:10
  • 1
    try to ssh login to it and see what happens
    – Camden
    Commented Jul 19, 2017 at 14:10
  • can you log in?
    – Camden
    Commented Jul 19, 2017 at 14:14
  • No, I can't it flickers infinitely
    – Drakota
    Commented Jul 19, 2017 at 14:15

4 Answers 4

8
  1. Uninstall the Windows driver that allows you to read/write to Ubuntu EXT4 partitions.

  2. To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

Update #1:

  • boot to the GRUB menu
  • select Ubuntu
  • hit the e key
  • use arrow keys to move
  • find the line that has "quiet splash"
  • add nomodeset, so "quiet splash nomodeset"
  • hit F10 to exit and continue boot
  • see if it flickers

Update #2:

Your recently installed Nvidia driver is causing your problem. In maintenance mode, uninstall/purge all *nvidia* software, reboot, then use Software & Updates, Additional Drivers tab, to reinstall Nvidia tested version, then reboot.

11
  • I don't think this is it, I had the same problem before installing the driver to read my Linux partition, I installed it like 10 min ago to get some files onto my Windows partition.
    – Drakota
    Commented Jul 19, 2017 at 14:42
  • @Drakota did you perform the fsck?
    – heynnema
    Commented Jul 19, 2017 at 14:50
  • Yes and I didn't get any error messages and I still get the flickering.
    – Drakota
    Commented Jul 19, 2017 at 14:51
  • Did it flicker when you did the fsck? Do you have Nvidia?
    – heynnema
    Commented Jul 19, 2017 at 14:54
  • 1
    Go back to the # prompt and type dpkg -l *nvidia* | grep ii and copy/paste results into your question.
    – heynnema
    Commented Jul 19, 2017 at 15:05
2

I recently had the blinking screen on a dual boot Ubuntu 18 and Windows 10 machine and the boot sequence seemed to be stuck. When I tried CTRL+ALT+DEL a message was displayed that unattended updates was in progress. At some point the blinking stopped and a finished message appeared. The machine rebooted, and everything was normal after that.

1

I installed bumblebee-nvidia in a terminal session and was able to login. Still haven't figured what happened in the first place, but at least it works for now. Thanks for the help everyone.

1
  • For what it's worth, I installed bumblebee just now, rebooted and there was no blinking display. It had just started to do that a few updates ago, so I have no idea which one caused it as I often put the computer to sleep at night. Commented Apr 16, 2018 at 13:59
-1

I had exactly the same problem today. My Ubuntu 18.04 had been working like forever, but today it wouldn't allow me to ssh into. A reboot paused somewhere with no apparent errors, with screening flickering. Pressing ALT+F2 showed the login prompt, but with screening flickering, no matter how fast I typed, the login was not correct.

In the end, it turned out it's my root partition was full. A specific program was generating data continuously and filled up the partition.

The quickest way to free up more space would be go to recovery mode in GRUB, then go to the root shell.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .