I have successfully installed Ubuntu 14.04 on a Lenovo machine that runs Windows 10 After the installation is finished, the machine restarts and automatically boots into Windows every time I start the machine. I have checked the boot list but Ubuntu is not there although I got successful installation message. Also the directory that I selected for Ubuntu to be installed in disappeared from Windows directories. My machine runs in BIOS Legacy mode and the System Information tells me that Secure Boot State is unsupported. I tried the startup repair but with no luck. And when I change mode from legacy to UEFI I get no boot loaded other than the IPv4 and IPv6 ones which fail to load anything. Three questions:

  1. How to make the directory where I installed Ubuntu visible in Windows?

  2. How can I get a boot window to select an OS to boot the machine into every time I open the machine?

  3. And before all, how from Windows, can I verify that Ubuntu was in fact installed properly?

  • 1
    See askubuntu.com/questions/221835/… , . It helps to READ ALL OF THE FIRST ANSWER but at least scroll down to the sectoin "TROUBLESHOOTING YOUR COMPUTER BOOTS DIRECTLY TO WINDOWS" – Panther Jul 19 '17 at 4:30
  • @waltinator I found the articles u gave helpful. Thanks for that. – Matar Jul 19 '17 at 4:53
  • @bodhi.zazen I already did go through the similar questions and tried methods suggested there but in vain. But thanks anyway for trying to help – Matar Jul 19 '17 at 4:54
  • Well, first you need to install (or convert) ubuntu with uefi enabled. I usually leave secure boot enabled as well, but you can leave that. Reinstalling is easier and faster as this is a fresh install of ubuntu. If ubuntu is not in your bios menu, then run boot repair and post the url it gives. help.ubuntu.com/community/Boot-Repair – Panther Jul 19 '17 at 4:59

Browse other questions tagged or ask your own question.