27

How can I disable the Windows key (or Super) from showing the GNOME Shell Activities overlay?

  • 2
    Yes, so annoying, it freezes the whole computer for 10 seconds everytime. I never pressed that key on purpose, but often press it by mistake when using Windows+Something combination keys. – Nicolas Raoul Nov 16 '16 at 7:03
12

You could try this: Open your gnome-shell, type keyboard layout and open it up. There should be three tabs in this window. Click the one on the right that says "Layouts." Click the "Options" button in the bottom-right corner of the window. You should see a list with the entries preceded by arrows. The third one down says "Alt/Win key behavior." Click this and it will drop down a list of options. The second-to-last option is "Meta is mapped to left Win key." Choose this one, close out the layouts menu, and it should be disabled.

| improve this answer | |
  • 2
    As an Ubuntu newcomer, it took me a bit to understand what "open gnome-shell" meant. (In Ubuntu 11.10) Click "Dash Home" (default upper right). In the search field, type "keyboard layout". Or open "System Settings", select "Keyboard Layout". – David Poole Mar 27 '12 at 21:13
  • What is the different between 'Meta is mapped to left Win key' and 'Meta is mapped to Wins key'? – Ooker Apr 16 '14 at 16:25
  • 2
    There is no "Options" button anymore: i.imgur.com/GwquDHf.png And none of the shortcut is just "Super". – Nicolas Raoul Sep 20 '16 at 9:56
  • This answer is no longer correct. The answer below referring to the gnome-tweak-tool is right. – JinnKo Sep 18 at 8:57
32
+50
  • gnome-tweak-tool > Keyboard and mouse > Switch between overview and desktop offers only 2 options:

    1. Left super, Default
    2. Right super

    enter image description here
    Switching the option to 'Right super' should do the trick.

  • However you may set up custom shortcut using:

    dconf write /org/gnome/mutter/overlay-key "'Alt_R'"
    

    or

    gsettings set org.gnome.mutter overlay-key 'Alt_R'
    
| improve this answer | |
  • 3
    I don't have a Right Super, so switching the option to Right Super seems to do the trick :-D I will check whether it survives a reboot. – Nicolas Raoul Nov 17 '16 at 2:43
  • 2
    Such an annoying "feature." This should be the accepted answer as the above settings only exist in Ubuntu, not other distributions of Gnome. – taranaki Mar 15 '17 at 20:08
  • 1
    “Switching the option to 'Right super' should do the trick.”—What if you have a right-side Windows key as well? – Guildenstern Sep 13 at 12:00
  • @Guildenstern yes that works too. – user.dz Sep 18 at 10:00
18

You can disable it by doing:

gsettings set org.gnome.mutter overlay-key ""
| improve this answer | |
  • 3
    I find that when the super keypress alone is bound to something, super+whatever combo keypresses are sometimes missed. Removing this binding as explained here seems to fix that. I just set Super+space as an alternative way to bring up the overview. – Shimon Rura Mar 12 '18 at 17:58
  • nice, works without the tweaks tool – benzkji May 29 at 7:48
  • I haven’t tried all the answers here but it seems that other ones have other effects that might not be desirable (“switch to right-super”, “meta is mapped to left win key”). I’ve wanted to disable this shortcut since I accidentally tap the left super key quite often. Thanks. – Guildenstern Sep 13 at 12:03
2

An update to faux-sho's answer you can now disable it using gnome-tweaks. You will have to install it using the software center.

Open it by searching for "Tweaks", and navigate to Keyboard & Mouse -> Additional Layout Options -> Alt/Win Key behaviour and select "Meta is mapped to Win".

| improve this answer | |
  • THANK YOU THANK YOU! I've been using Linux for a few months and this has been literally JARRING me out of my workflow since I started. In my text editor Ctrl + G opens up a field which lets you type file paths. Until just now I wasn't able to use that. – commadelimited Jul 20 at 19:55
0

Enable the Start Overlay in Application View gnome extension and everything sorted https://extensions.gnome.org/extension/1198/start-overlay-in-application-view/

| improve this answer | |
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – mook765 Nov 6 '18 at 7:57
  • 3
    But @mook765 It's not a "link-only" answer per se. This answer suggests using a GNOME extension and provides a link to the extension's homepage, whereas link-only answers are answers that point to somewhere else where there is claimed to be an answer, rather than answering the question itself. – pomsky Nov 7 '18 at 7:17
0

Go to System Settings => Keyboard => Layout => "Win" Key Behaviour; Choose the desired option from the drop down list;

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.