According to this answer, I can disable apport by editing /etc/default/apport and setting enabled=0.

I have done this:

$ cat /etc/default/apport
# set this to 0 to disable apport, or to 1 to enable it
# you can temporarily override this with
# sudo service apport start force_start=1

In fact, you can see I actually did this in December 2016:

$ stat /etc/default/apport
  File: '/etc/default/apport'
Modify: 2016-12-22 09:43:01.688938268 -0500

Recently I noticed apport was running, so I stopped it and, then rebooted to see if it would come back again

$ sudo service apport stop
$ sudo reboot

However, on startup, it is indeed active again:

$ service apport status
● apport.service - LSB: automatic crash report generation
   Loaded: loaded (/etc/init.d/apport; bad; vendor preset: enabled)
   Active: active (exited) since Tue 2017-07-18 11:27:44 EST; 45min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1395 ExecStart=/etc/init.d/apport start (code=exited, status=0/SUCCESS)

Jul 18 11:27:44 foobar systemd[1]: Starting LSB: automatic crash report generation...
Jul 18 11:27:44 foobar systemd[1]: Started LSB: automatic crash report generation.

You can see I rebooted my machine at 11:27, so apport is being started at startup

$ sudo last reboot
reboot   system boot  4.4.0-83-generic Tue Jul 18 11:27   still running

How can I permanently disable apport?

  • That is the method and if it is not working you should file a bug report. Either apport is not conformaing to its config file (bug) or the ubuntu documentation on apport needs to be updated.
    – Panther
    Jul 18, 2017 at 17:38
  • Since 16.04 is systemd-based, you should be using systemctl to disable/mask unwanted services - see for example How do I disable unnecessary services without uninstalling them in Ubuntu 15.10? Jul 18, 2017 at 17:40
  • @steeldriver While that is true, apport should follow it's config file regardless , so IMO this is a bug.
    – Panther
    Jul 18, 2017 at 17:44
  • I updated my answer to add systemd info but I still suggest filing a bug report.
    – Panther
    Jul 18, 2017 at 17:50

1 Answer 1


The systemd commands would be


sudo systemctl disable apport.service

If that does not work, you need to mask the service

systemctl mask apport.service

To reenable

systemctl unmask apport.service
sudo systemctl enable apport.service
  • Using systemctl disable apport worked for me, thanks Jul 18, 2017 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .