4

I have a Sennheiser HD 4.4, I can connect it to my 14.04 Ubuntu. I also set the configuration on A2DP using pavucontrol and it works for a while. But after like two minutes everything which plays any sound freezes and the headphone itself is removed from the output sinks and also the connection bar in the Bluetooth setting turns off as in the picture posted! As soon as I disconnect the headphones, YouTube will start working normally

enter image description here

This will be fixed if I restart the computer and do the pairing process from the beginning. But after several minutes it will go crazy again.

As requested this is the output of lspci -knn | grep Net -A3; lsusb after the problem occurred:

04:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
Subsystem: Dell Device [1028:0209]
Kernel driver in use: ath9k
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0bda:0184 Realtek Semiconductor Corp. RTS5182 Card Reader
Bus 003 Device 004: ID 045e:07a5 Microsoft Corp. Wireless Receiver 1461C
Bus 003 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 003 Device 005: ID 0cf3:e004 Atheros Communications, Inc. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
2
  • Please edit your question and add output of lspci -knn | grep Net -A3; lsusb terminal command.
    – Pilot6
    Jul 18, 2017 at 19:59
  • @Pilot6 I updated the question.
    – D3GAN
    Jul 18, 2017 at 21:00

2 Answers 2

3

Some user reports huge delays or even no sound when the Bluetooth connection does not send any data. This is due to the module-suspend-on-idle module, which automatically suspends sinks/sources on idle. As this can cause problems with headset, the responsible module can be deactivated.

To disable loading of the module-suspend-on-idle module, comment out the following line in the configuration file in use (~/.config/pulse/default.pa or /etc/pulse/default.pa):

### Automatically suspend sinks/sources that become idle for too long
#load-module module-suspend-on-idle

Finally restart PulseAudio to apply the changes.

Source: https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Bluetooth_headset_replay_problems

1
  • 1
    Awesome, than you very much. Nov 6, 2021 at 20:58
1

This is the problem with simultaneous usage of Wi-Fi and bluetooth. They share the same radio frequency at 2.4 GHz. You can fix it by turning on bluetooth coexistence feature.

Run in a terminal

sudo tee /etc/modprobe.d/ath9k.conf <<< "options ath9k btcoex_enable=1"

and reboot.

1
  • I tried this it didn't help.
    – D3GAN
    Jul 20, 2017 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.