I've just upgraded from 14.04 LTS to 16.04 LTS. I am using Compiz as window manager. Unfortunately I am no longer able to use the mouse wheel on the workspace pane (bottom right on screen) to scroll forward/backward between the workspaces.

I have CompizConfig Settings Manager installed, but cannot find such a setting in it. Is there a way to enable this feature again?

    – kevy
    Jul 18, 2017 at 15:10
  • @VinuKevy: Ctrl+Alt+Arrow-Key is working. Ctrl+Alt+Mouse-Wheel is not doing anything. Jul 18, 2017 at 15:13
  • @JennyO'Reilly You should place your cursor over a window tray before using Ctrl+Alt+Mouse Wheel
    – Dami
    Sep 5, 2018 at 9:55
  • 3
    Possible duplicate of How to switch workspace with mouse wheel in Unity May 29, 2019 at 23:01

2 Answers 2


To do so (presuming you have compizconfig-settings-manager installed)

Go to Desktop > Viewport Switcher.

enter image description here

It shows 20 buttons by default, which doesn't mean you actually can trigger 20 buttons.

To check which ones work, you can use the xev command. Type the command into a terminal, ensure the xev window has focus and then try your buttons.

enter image description here

  • Well it does seem to work with "button 4" and "button 5", but only if no program has the focus. For example if I have a firefox window open, it scrolls the page up/down instead of switching the workspace. I also tried it with some combinations (ctrl, shift, alt or super). But it is the same. Any ideas? Jul 18, 2017 at 16:30

It turns out that I was using the wrong window manager after the update to Ubutnu 16.04 LTS. In Ubuntu 14.04 LTS I was using Metacity which has this feature of switching workspaces with the mouse wheel by default. So I simply switched from Compiz back to Metacity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.