I have in the past on the same laptop been able to get TV out and S-Video out working, but now I cannot do it. The VGA output works fine, but I cannot connect it to any TV that does not have that.

The documentation seems pretty sparse on this one, and the fact that with previous versions of Ubuntu it worked makes this problem more irritating.

Here is the relevant output of lspci.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03) (prog-if 00 [VGA controller])
    Subsystem: Acer Incorporated [ALI] Device 0133
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at fc000000 (64-bit, non-prefetchable) [size=1M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 1800 [size=8]
    Expansion ROM at  [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 3
    Kernel driver in use: i915
    Kernel modules: intelfb, i915

This has all worked with this exact laptop before, so that makes it even more annoying.

Has anybody else had this kind of experience and how did you fix it?

  • I tried getting video output with a 10.10 live cd, and it works with just the live cd. I will have to try with an 11.04 live cd but at this stage I think a downgrade to 10.10 might be on the cards. – bjem Jan 8 '12 at 10:23
  • Confirmed that it does not work with an 11.04 live cd, so a downgrade to 10.10 it is. – bjem Jan 8 '12 at 21:09

For me, the answer was a downgrade to Ubuntu 10.10. Getting TV-out worked off the live cd.


My patch would break tvout support for other cards so I won't submit it as a patch. I can say I found the problem and have locally fixed it. In the kernel code there is kernel/drivers/gpu/drm/i915/intel_tv.c that has a function called intel_tv_init( struct drm_device *dev) at the line +-1550. In there the driver checks for tv outyness. If you look at the function, there are many points at which the init can fail. My asus A51e failed in the checking vbts section. through the miracle of slash slash based optimisation, I removed that check and now I have tvout working on the laptop with 3.2.x I will check if it works with 3.11+.

You need to get the kernel code from git and then apply a patch.


git checkout 

apply the fix. copy a .config from your /boot dir to your src dir

make -j #cpus +1
make -j #cpus +1 modules
make -j #cpus +1 modules_install 
make -j #cpus +1 deb_pkg
cd .. 
dpkg -i linux*.deb


  • This is really unclear on how the user can use this answer to solve their problem. – Julian Stirling Jan 5 '14 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.