4

I follow many ways for installing my .deb file (VirtualBox amd64 that I downloaded from virtualbox.org) and also follow this article but when I typed:

sudo apt-get install virtualbox-5.1

or ran the below code:

sudo apt-get install virtualbox 5.1

I got the following error:

E: Package 'virtualbox-5.1' has no installation candidate

UPDATE 1:
When I typed sudo dpkg -i virtualbox-5.1.deb I got the following error message:

Selecting previously unselected package virtualbox-5.1.deb
(Reading database ... 193670 files and directories currently installed.)
preparing to unpack virtualbox-5.1.deb ...
Ubpacking virtualbox-5.1 (5.1.22-115126~Ubuntu~xenial) ...
dpkg: dependency problems prevent configuration of virtualbox-5.1:
 virtualbox-5.1 depends on libqt5x11extras5 (>= 5.1.0); however:
  Package libqt5x11extras5 is not installed.

dpkg: error processing package virtualbox-5.1 (--install):
 dependency problems - leaving inconfigured
Processing triggers for systemd (229-4ubuntu16) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utuls (022-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
   virtualbox-5.1

UPDATE 2:
Error when I type libqt5x11extras5:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libqt5x11extras5 is not available, but is referred to by another package.
This may mean that the package is missing, hass been obsoleted, or is only available from another source

E: Package 'libqt5x11extras5' has no installation candidate

UPDATE 3:
When I enter apt download libqt5x11extras5 I received this error:

E: Can't select candidate version from package libqt5xextras5 as it has no candidate

note: I download the Oracle_VM_VirtualBox_Extension_Pack-5.1.22-115126.vbox-extpack manually and click on it to install or run but it run for a few second and the close, and shows anything!

and when download libqt5x11extras5 manually and try to install it, this error shows:

E: Unable to locate package libqt5x11extras5_5.5.1-3build1_amd.deb
E: Couldn't find any package by glob 'libqt5x11extras5_5.5.1-3build1_amd.deb'
E: Couldn't find any package by regex 'libqt5x11extras5_5.5.1-3build1_amd.deb'
7
  1. Visit the official Download VirtualBox for Linux Hosts webpage.

  2. Manually download the VirtualBox 5.1.xx for Linux AMD64 .deb file for Ubuntu 16.04. Update: The latest version of VCirtualBox is now 5.2.xx

  3. Open the terminal and change directories using cd to the directory that contains the virtualbox-5.1_5.1.14-112924-Ubuntu-xenial_amd64.deb file that you downloaded.

  4. Install VirtualBox. I have installed both virtualbox-5.1_5.1.14-112924-Ubuntu-xenial_amd64.deb and libqt5x11extras5 in Ubuntu 16.04 and they worked. You got an E: Package 'libqt5x11extras5' has no installation candidate error message when trying to install libqt5x11extras5, so you need to download libqt5x11extras5 separately in order to install it. Download libqt5x11extras5 from the official Ubuntu Download Page for libqt5x11extras5_5.5.1-3build1_amd64.deb on AMD64 machines. Paste libqt5x11extras5_5.5.1-3build1_amd64.deb in the same directory as the virtualbox-5.1_5.1.14-112924-Ubuntu-xenial_amd64.deb file that you downloaded.

    sudo apt update  
    sudo apt install dkms  
    sudo apt install ./libqt5x11extras5_5.5.1-3build1_amd64.deb
    sudo apt install ./virtualbox-5.1_5.1.14-112924-Ubuntu-xenial_amd64.deb
    
  5. You also might want to download Oracle's matching Extension Pack for virtualbox-5.1_5.1.14-112924-Ubuntu-xenial_amd64.deb which is a file named Oracle_VM_VirtualBox_Extension_Pack-5.1.14-112924.vbox-extpack. To install it right-click the Oracle_VM_VirtualBox_Extension_Pack-5.1.14-112924.vbox-extpack file and from the popup menu select Open With Oracle VM VirtualBox. Oracle VirtualBox application will open and show this window:

    enter image description here

  • 3
    Since this is 16.04, you can use apt: sudo apt install ./virtualbox-5.1_5.1.14-112924-Ubuntu-xenial_amd64.deb, and it will take care of dependencies. – muru Jul 18 '17 at 5:08
  • i have update my question ;) – jalil Jul 18 '17 at 8:06
  • You have the universe repository enabled in Software & Updates -> Ubuntu Software tab -> second line in the list, right? – karel Jul 18 '17 at 8:16
  • 1
    YES! it's run and i test if it will be disabled!!! – jalil Jul 18 '17 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.