I have a "Gigabyte X299 Gaming 7"-motherboard, which has the Realtek ALC1220 sound chip.

I can listen to sounds using the front panel audio on my computer, but when I remove the headphones, I don't get output through the back panel output connector. This works in Windows, so it can't be that the hardware is broken.

Since the headphones work (with great audio quality!), I'm guessing that the problem is really simple, some kind of audio switch that has to be activated in order to have analog sound routed to the rear port.

Can anyone give me any pointers on what to investigate?

During boot, I get the following kernel output:

[    3.436058] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1220: line_outs=3 (0x1b/0x15/0x16/0x0/0x0) type:line
[    3.436060] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.436060] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x14/0x0/0x0/0x0/0x0)
[    3.436061] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    3.436062] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[    3.436062] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    3.436063] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    3.436064] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[    3.436064] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[    3.445462] random: crng init done
[    3.447417] input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input3
[    3.447565] input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input4
[    3.447715] input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1f.3/sound/card0/input5
[    3.447862] input: HDA Intel PCH Line Out Front as /devices/pci0000:00/0000:00:1f.3/sound/card0/input6
[    3.448003] input: HDA Intel PCH Line Out Surround as /devices/pci0000:00/0000:00:1f.3/sound/card0/input7
[    3.448134] input: HDA Intel PCH Line Out CLFE as /devices/pci0000:00/0000:00:1f.3/sound/card0/input8
[    3.448231] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input9

Maybe the "autoconfig" hasn't gone right? Is there some way to make a "manual" config instead?

In lshw I get the following:

             description: Audio device
             product: 200 Series PCH HD Audio
             vendor: Intel Corporation
             physical id: 1f.3
             bus info: pci@0000:00:1f.3
             version: 00
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi bus_master cap_list
             configuration: driver=snd_hda_intel latency=32
             resources: irq:83 memory:92f40000-92f43fff memory:92f20000-92f2ffff

Some info from lspci:

00:1f.3 Audio device [0403]: Intel Corporation 200 Series PCH HD Audio [8086:a2f0]
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:a0c1]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
  • 1
    Maybe just use the Sound Indicator to toggle audio outputs? Unlike Windows it isn't automatic.
    – user692175
    Jul 17, 2017 at 22:03
  • I've tested that, and it doesn't help. Pulse audio volume control gives no hint that nothing is playing. It is only that there in fact is no signal on the rear panel output.
    – avl_sweden
    Jul 17, 2017 at 22:08
  • When I plug something in on the rear panel, it shows as "plugged in", and can be chosen as an output. There just is no sound.
    – avl_sweden
    Jul 17, 2017 at 22:09

2 Answers 2


Gigabyte X299 Gaming 7 has two audio outputs on the back. Analog and digital. Digital is set to default on fresh system. To use audio jack I had to change the default port of audio device.

This can be changed in gui in pavucontrol. I selected "Headphones (unplugged)" in Output Devices tab in Port combo box:

enter image description here

This made my rear analog port work. Unfortunately I had to do it after every power cycle (maybe because false negative unplugged state).

To do the same thing in command line we need port name. Use pacmd list-sinks. My printed this port section:

    analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: yes)

    analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
            device.icon_name = "audio-headphones"

So we have our port name, now you can set it as default from command line:

pacmd set-sink-port 0 analog-output-headphones

To make it persistent across reboots, add line set-sink-port 0 analog-output-headphones to pulse audio config file: /etc/pulse/default.pa

  • Original poster here. I don't have the hardware any more, so I can't verify your fix. But I can tell you put a lot of work into your answer, and wanted to accept it just because of that.
    – avl_sweden
    Nov 17, 2019 at 21:36
  • Thanks! I'm also posting such stuff for myself, to find it after next format :)
    – Dorian
    Nov 18, 2019 at 10:40
  • This was super helpful thank you. Got me right up and working! Apr 8, 2020 at 2:47

I had (fix it) exactly the same problem (headphones work, in Windows dual boot sound works, HW is ALC888). I hit it after upgrading from Ubuntu 12.04 to 17.04. Knowing that HW is OK and that it worked on my previous LX installation, I boot Ubuntu 12.04 from CD and look at Sound Settings for what is different. To make my rear sound work again in Ubuntu 17.04 I had to lunch pavucontrol and change Configuration for Built-in Audio to "Analog Surround 5.1 Output+Analog Stereo Input". After my upgrade to 17.04, it was set to "Digital Stereo (IEC958) + Analog Stereo Input". There are other pavucontrol Configuration options, but I did not experiment further. I have my rear output sound back. Settings are OK also after power cycle.

  • Good input! That's not it in my case though, since I've tried the different configuration options with no result.
    – avl_sweden
    Aug 17, 2017 at 5:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .