0

I connected to my server's Ubuntu 14.04 VM via Windows Remote Desktop Connection. After logging out of the session I checked the processes running with top command in a putty session and saw Xvnc processes still running on the system. Following command

ps -ef | grep Xvnc

outputs:

zebi2    63444     1  0 12:57 ?        00:00:00 Xvnc :10 -geometry 1364x768 -depth 24 -rfbauth /home/zebi2/.vnc/sesman_zebi2_passwd -bs -ac -nolisten tcp -localhost -dpi 96
zebi2    64981 37219  0 13:00 pts/16   00:00:00 grep --color=auto Xvnc

First line is what I am actually concerned about. I run RDC many times a day and it creates an additional process every time. I don't want to kill the process every time I logout of RDC, also I cannot leave the process since it will increase cpu utilization . Any help or solution is appreciated

  • How did you setup / configure the VNC/RDP server? it's probably a matter of adding the appropriate VNC flag (-once ) to the session manager ini file. – steeldriver Jul 17 '17 at 12:40
  • Thanks for the help. I have posted the answer which solved the issue. – Somesh Zalani Jul 19 '17 at 10:09
1

Turns out it was session cache history which might have been saved previously.

  1. Unticked 'automatically save session' in 'Session and Startup' in XRDP desktop settings

  2. Cleared $HOME/.cache/sessions/xfce4-session-* (all of the previously saved session data).

  3. And restarted xrdp service

This link helped https://forum.xfce.org/viewtopic.php?id=6580

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.