0

I have a dual-boot system that was running Windows 10 and Ubuntu for the last year or so. I am using an Intel 600p 256 GB m.2 SSD (where windows files are located) and a 1 TB WD Blue HDD using a sata III slot 0 (used for extra storage and where Ubuntu was installed). In the last month occasionally I have booted into windows 10 and my D: drive, the HDD is not recognized by windows. A reboot or two has fixed this issue in the past. I just ran into this issue again but now it takes about 6 min to load windows 10 after grub-bootloader selection is made (30 sec tops in the past) and the HDD isn't there.

I deleted the Ubuntu partitions and fixed windows boot (since Ubuntu/grub is missing after deleting these partiton) and the HDD is back just like it should be. I tested this over several boots with no problems. I have now installed Lubuntu on the SSD beside windows 10 and immediately have the same issue with extremely slow loading times and missing HDD.

The BIOS always recognizes both the SSD and HDD. In Ubuntu or Lubuntu, both drives have always been there with no problems and I can get my stored files from either disk. In Windows 10 I cannot find the HDD as it is not in file explorer, and disk management doesn't even show there is a second disk.

I know this was long, but I tried to give all of the details. I am new to the forum, so if there is something I missed please let me know.

0

I currently have this problem and figured out that the two drives that I cannot see are set up as dynamic for some reason. Im gonna have to format the drives and set back to basic through windows.

  • Thank you, this appears to have fixed the issue. Here are the steps I completed for future reference. I backed up the data to another drive and deleted the partitions on the HDD. I then tried it, but had the same issue. I then used a windows 7 install dvd just to format the drive since windows wouldn't see it. Put my system back together and booted into windows 10. It found the disk so I reformatted it into one large partition instead of the small partition and large partition that windows 7 install dvd put on it. Everything is working correctly now. – linuxfun Jul 17 '17 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.