1

My wifi suddenly stopped working even after reboot

sudo lshw -C network gives this

*-network
  description: Ethernet interface 
  product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
  vendor: Realtek Semiconductor Co., Ltd. 
  physical id: 0 
  bus info: pci@0000:05:00.0 
  logical name: eth0 version: 06 
  serial: 24:b6:fd:27:e1:b8 
  size: 10Mbit/s 
  capacity: 1Gbit/s 
  width: 64 bits 
  clock: 33MHz 
  capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation 
  configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s 
  resources: irq:30 ioport:e000(size=256) memory:f1104000-f1104fff memory:f1100000-f1103fff 
*-network 
   description: Ethernet interface 
   physical id: 2 
   logical name: usb0 
   serial: fa:dd:3b:86:b9:76 
   capabilities: ethernet 
   physical configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.167 link=yes multicast=yes

My wifi device is intel centrino wireless n 1030 (rainbow peak)


i tried changing the iwlwifi.conf but could not be of any help then on the website i found a download https://www.intel.in/content/www/in/en/support/network-and-i-o/wireless-networking/000005511.html

these were the instructions given To install firmware:

Copy the files into the distribution-specific firmware directory, /lib/firmware.
If the directory does not work, consult your distribution documentation.
If you configure the kernel yourself, make sure firmware loading is enabled.

please note there are other two files than the iwlwifi-6000g2b-5.ucode file which does not require to be copied (one is license and the other is readme) and then it was up again

however a new problem was encountered wifi dropping after few hours

dmesg | grep iwl gives the follwoing

[   20.654434] iwlwifi 0000:09:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[   21.575195] iwlwifi 0000:09:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   21.575199] iwlwifi 0000:09:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   21.575200] iwlwifi 0000:09:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   21.575203] iwlwifi 0000:09:00.0: Detected Intel(R) Centrino(R) Wireless-N 1030 BGN, REV=0xB0
[   21.575256] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[   21.595943] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   27.574648] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[   27.581175] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[   27.581262] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1
[   27.648799] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[   27.655322] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[   27.655409] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1
[ 2240.088860] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[ 2240.095386] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[ 2240.095475] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1
[ 2240.163097] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[ 2240.169634] iwlwifi 0000:09:00.0: L1 Disabled - LTR Disabled
[ 2240.169729] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1

i aslo have refrred to the bug reporting https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1420935 have tried the following Create a file named: /etc/modprobe.d/wifi_bug.conf

Add the following lines to the file: options iwlmvm power_scheme=1 options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1

Set the file's ownership the same as other files in that folder.

Reboot.

worked for a while , problem persists as of now the kernel version i am using is 4.4.0-130-generic

13
  • @Zanna after the above the wifi adapter was up , but a new issue of wifi drop after few hours was noted . please add the needful . – sassy.geek Jul 16 '17 at 7:45
  • What exactly did you change in the iwlwifi.conf? – Thomas Jul 16 '17 at 8:40
  • @Thomas options iwlwifi 11n_disable=1 to options iwlwifi 11n_disable=8 – sassy.geek Jul 16 '17 at 9:34
  • @Thomas and then since it didnt work then i reverted back to the previous that is options iwlwifi 11n_disable=1 – sassy.geek Jul 16 '17 at 9:40
  • @Pilot6 please let me know what else needs to be added.. this was all i did, awaiting your help ! – sassy.geek Jul 16 '17 at 15:02
0

From this answer: Reset WiFi you can power your WiFi off and on again after a reboot. This will simulate the physical power button cycling off and on which works for your laptop.

0

Hardware Testing Required

https://askubuntu.com/a/1065770/623433

this is the solution that worked for me

2
  • After the test did you install new hardware? – WinEunuuchs2Unix Aug 22 '18 at 3:46
  • @WinEunuuchs2Unix i have mentioned in a comment stating that , i called the dell engineer to pay a visit for service , he came , opened the laptopp, cleaned upa abit by removing almost all the chips i cant tell , but surely the wifi card was removed and cleaned as well and to my surprise , the wifi started working ! i have accepted : futher hardware testing as the most suitable answer for me ! i have also tested it with 14.04 and 18.04 on live sticks by multiple reboot. – sassy.geek Aug 22 '18 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.