1

I did a clean install of Ubuntu Gnome today. I installed cinnamon and switched to it (I left gnome installed). I was customizing the theme, and all settings were taking effect immediately, but I can't change the icon theme. Even if I select a theme and logout and back in nothing changes. Also, if I close the theme window and reopen it, it still has the icon theme that I chose, but it has the icon from the default Adwaita displayed. I ran updates and restarted, and now there is no desktop background and the ctrl-alt-T shortcut for terminal isn't working. I have tried reinstalling cinnamon, and nothing changed. I am running Cinnamon 3.2.7 on Ubuntu Gnome 17.04.

tldr;

When I select a theme for icon in cinnamon nothing happens. I can change all of the other theme settings. After a reboot the desktop is black and some keyboard shortcuts don't work.

0

OK, so after much experimentation I found a workaround, and a more permanent solution.

The Workaround

There were multiple issues, with separate solutions.

To solve the issue of the background being dark, I had to switch from the gnome greeter to lightdm:

sudo dpkg-reconfigure gdm3

...and then select lightdm. Now Cinnamon used the background from the greeter, which could be changed with the lightdm GTK+ greeter settings tool. This is not ideal, but it works.

To change the icon theme, I had to use the gnome tweak tool. I don't know why, but that correctly changed the icon theme.

As for the default keyboard shortcuts, I had to add them again. Instead of using the built in 'launch terminal' shortcut, I had to make a custom shortcut that ran gnome-terminal. Not ideal, but it works.

The Longer-Term Solution

I still don't know exactly which programs were causing these issues, but I figured that the cleaner the install I could do the better.

I reinstalled, this time with the minimal ubuntu installer. After that, I installed cinnamon, and enabled lightdm, using instructions from this answer.

sudo apt-get install cinnamon-desktop-environment
sudo systemctl set-default graphical.target

in /etc/default/grub change the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash init=/lib/systemd/systemd"

and finally run

sudo update-grub

This gave me a working cinnamon install on Ubuntu. To get a nicer and more configurable greeter, I also installed the lightdm GTK+ greeter, and settings tool.

sudo apt-get install lightdm-gtk-greeter lightdm-gtk-greeter-settings
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.