0

When I try installing nvidia drivers for my GTX 1080 Ti and reboot, I have an infinite login loop.

I've been trying to install Ubuntu 17.04 on my Lenovo Y900 desktop, and here's what I have so far: I had to disable secure boot and disable ACPI (acpi=off in boot code) in order to make Ubuntu run on my machine. That might be unrelated to my issue. Then, I was able to log on and everything works fine except that there's something wrong with my video card (GTX 1080 Ti).

The only resolution option is 800x600. Also, the only display I see in the "display" menu is "built in display"; I'm not sure what that means, but I'm using an external monitor (1920x1080). So, I installed nvidia drivers.

I used

sudo apt-get install nvidia-XXX

where I tried a few different values for XXX, and then I reboot. Each time, I'm able to get to the login screen, but when I log on it goes to a black screen with a flashing text dash on the top-left, and then goes back to the login screen. I am able to undo driver installations by using

sudo apt-get purge nvidia*

I have tried both of these (one at a time):

nomodeset
nouveau.modeset=0

I have tried reinstalling the Unity, Ubuntu desktop, and xorg. I have also tried chown .Xauthority and deleting .Xauthority, and after different combinations of what I've just mentioned, I've used

service lightdm restart

Any tips? Thanks! (Also, first time Linux user; sorry if I'm pretty incompetent with it)

  • Did you try deleting .Xauthority? – NerdOfLinux Jul 15 '17 at 20:31
  • @NerdOfLinux I just did; I tried deleting it then logging in, and then deleting it, rebooting, and logging in. Neither worked. – Makusu2 Jul 15 '17 at 20:44
  • 1
    Disable Secure Boot in BIOS. – Pilot6 Jul 15 '17 at 21:31
  • @Pilot6 Already done – Makusu2 Jul 15 '17 at 21:38
0

Fixed issue: I had to change "acpi=off" to "pnpacpi=off"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.