0

I can't seem to mount a share that worked just fine in Ubuntu 16.04 32bit Server, but I get a mount error(13): Permission denied error in Ubuntu 17.04 32Bit Server. There are number of reasons why I can't downgrade back to 16.04, so that isn't an option. Did something change in the cifs-utils package, or some change in the kernel that's preventing me from accessing this? I'm out of ideas, and have searched relentlessly trying to find an answer.

I have my username=<username> and password=<password> in a .smbcredentials file, which worked in 16.04. Then in /etc/fstab:

//<share_name>.net/Projects/BuildsArea /Volumes/Projects/BuildsArea cifs credentials=/home/admin/.smb/.smbcredentials,uid=1001,gid=1001,file_mode=0777,dir_mode=0777,_netdev,mand,nounix,noserverino 0 0

Where the share_name is just a host name to a fileshare that I've used previously. Any ideas on what's going on here? Running sudo mount -a -v just shows the permission error, and then spits out the mount.cifs kernel mount options. I've tried every sec= option, as well as using vers=3.0, but I don't think either of those options are going to help. If there is other information that would be helpful, just let me know. I've also made sure that the .smbcredentials file has is owned by the admin user account. Thanks in advance!

0

For anyone wondering, in my .smbcredentials file, I needed to have the domain=<domain_name> key as a separate key. Not sure why this is different in 17.04, maybe I'm missing something obvious? Regardless, it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.