I'm currently on Lenovo G580. I managed myself a dual-boot system with Windows 8.1 and Ubuntu 16.04 LTS installed in EFI mode (because my laptop refuses to carry them both not in EFI).

For some time my system works fine, however, after a few days Ubuntu suddenly breaks down. Firsly it gives me

    Support for core revisions 0x17 and 0x18 disabled by module param allhwsupport=0. Try b43.allhwsupport=1

Using this forum I figured it out that the problem is in wifi adapter or smth and people usualy skip this warning if their wifi works fine. Although I have no problems with wifi this message do not allow me to log in. I tried to fix it as it were suggested here. System launched and after a reboot crashed again with:

    /dev/sda6: clean, 293631/3276800 files, 1886635/13107200 blocks
    [20.845119] b43-phyO    ERROR: FOUND UNSUPPORTED PHY (Analog 10, Type 8 (LCN), Revision 1)
    [29.972408] atal.OO:    exception Emask 0x0 SAct 0x2000007 SErr 0x0 action 0x0
    [29.972481] atal.OO:    irq.stat 0x40000008
    [29.972497] atal.OO:    failed command: READ FPDMA QUEUED
    [29.972518] atal.OO:    cmd 60/00:00:cO:Oe:50/02:00:33:00:00/40 tag 0   ncq dma 262144 in
    [29.972518] res 41/40:00:08:Of:50/00:00:33:00:00/40 Emask   0x409 (media error) <F>
    [29.972569] atal.OO:    status: { DRDY ERR ]
    [29.972584] atal.OO:    error: { UNC }
    [29.985593] blk_updatejrequest: I/O error, dev sda, sector 860884744

This error-message repeats and it ends like this:

    [19.169477] Buffer I/O error on dev sda6, logical block 1101, async page read

    Error reading block 1101 (Attempt to read block from filesystem resulted in short read) while getting next inode from scan.
    (i.e., without -a or -p options) fsck exited with status code 4
    The root filesystem on /dev/sda6 requires a manual fsck
    BusyBox vl.22.l (Ubuntu l:l.22.0-15ubuntul) built-in shell (ash) Enter 'help1 for a list of built-in commands.

The thing is, that it is not dificult for me to reinstall the system. But this problem is arising in a few days after every reinstallation. No matter if I tried to fix that problem with wifi or not. While Windows works perfectly.

I'm not an advanced user of Linux and I need it only to work with programms for quantumn chemistry calculations (ABINIT). And that is exactly what I do. The only thing I do after installation is compiling ABINIT and installing some libraries to Python (numpy, scipy, simpy, matplotlib and ASE). But Ubuntu continues to crash without any reason. The last of my efforts to reinstall it ended up with a crash after only 1 reboot. Previous one stood for several weeks and dozens of reboots. The one before it maybe for 1 or 2 reboots. And so on ... This is quite annoying.

After searching through the topics I thought that the reason might be in hardware. Model of my HDD is Seagate ST1000LM024 HN-M101MBB (SATA) and sysmboard LENOVO INVALID (U3E1) (actually, I doubt that INVALID - means something good).

I would appreciate any recomendations or advices. How can I achive stable work of dual Windows/Ubuntu in my case? What is the problem so far? If the problem is with hardware - maybe I should bring it to service center and ask them to fix/change systemboard/HDD or the problem might be in software?

  • I'd try boot from usb or disc media utility like gparted, Lsoft Active or other utility and doing a full hdd scan. You can also try the Lenovo bios / hdd utlities if they have one. Looks like a bad hdd to me. May just need a more thorough scan than what OS is doing at boot. If it does show a failure, at least you have time to back up all your files vs. one day it just not be accessible. Jul 15, 2017 at 12:11

1 Answer 1


I think you've got two unrelated problems:

  • A PHY is a type of chip in network hardware. The warnings and errors you've cited related to that are therefore issues with your network hardware. This seems to be your less important problem.
  • More of your problems refer to ata1.00 or /dev/sda, which is your hard disk. These error messages include phrases such as short read and media error, which generally indicate failing hardware, but can sometimes be caused by buggy drivers, loose cables, etc.

I recommend you focus on the disk issue, since that's clearly the more serious one.

I've found references to the Lenovo G580 dating back to 2012, so this seems to be a rather old computer. As such, a driver bug seems unlikely, but is not impossible -- driver bugs for common devices like disks are most common in really new hardware.

If the computer provides easy access to the hard disk, you might try removing it and plugging it back in. If the problem is caused by a loose connection, this might fix the problem. I wouldn't hold out much hope, though.

The most likely issue is an actual hardware failure -- bad sectors or failing circuitry on the disk, or maybe on the motherboard. Checking the SMART status of the disk makes sense as a first step. That will confirm some types of hardware failures, if that's what's happening. Note, however, that SMART will miss some types of hardware problems, so if the SMART status looks OK, you'll be left with no real new information to help guide you.

If SMART suggests the drive is failing, you should replace the disk ASAP. Some types of disk failures get worse with time, sometimes unpredictably and rapidly, so you could go from a minor annoyance to a modest problem to a show-stopping catastrophe in a matter of minutes. Even if SMART does not return definitive signs of failure, replacing the disk may be in order for the same reason, but there's less guarantee that doing so would fix the problem.

On occasion, problems like this are caused by a failing trace or chip on the motherboard. On a laptop computer, that's essentially Game Over for the computer, since replacing the motherboard is likely to be tedious and expensive. (You might be able to get a replacement motherboard on eBay relatively cheaply, though.) Short of trying another hard disk, I don't know of a way to positively narrow down the problem as being on the motherboard vs. the hard disk -- but if SMART says the hard disk is failing, it almost certainly is on the hard disk, not on the motherboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.