0

In my downloads I have xampp-linux-x64-7.1.7-o-installer.run, but when I click it it tries to run and then throws an error saying I need to become a super user as root privileges are required. I tried typing sudo in the terminal and then dragging it into the terminal, same results. Can you help me use this app?

0

It is neither wise not advisable to install xampp on Ubuntu or any Linux distribution for that matter. Follow the instructions here http://howtoubuntu.org/how-to-install-lamp-on-ubuntu to install the LAMP stack. About permissions on Linux you need to supply the OS with a super user password (thinks Administrator from Windows but much more powerful). This is a security measure to ensure that only trusted software is installed.

| improve this answer | |
0

If Xampp does not work on your computer you can setup your own web developpment environement by issuing on a terminal the following command (you can add or remove packages as you need):

sudo apt install php5 apache2 php5-mysql mysql-server

This will install a web server on the computer plus a database server (mysql). If you prefer Sqlite you can install the php5-sqlite3 package instead of the php5-mysqland the mysql-server package.

If you are running Ubuntu 16.04 (Xenial) or older, replace php5 with php7.0 (php 5.0 is not available any more on official repositories since php7.0 was released.

apache2 is the webserver.

Please note that this server will run on the background of your computer, and this could provoke performance issues on old hardware...

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.