5

I tried to follow Luis Alvaro's instructions (on How to install and configure Wine?) but still can't get Foxit PhantomPDF Business to install, let alone run.

  • I tried both versions 7 and 8 (available as free trial download from the link above).

  • I tried loading all sorts of winetricks.

  • In the install, I chose "custom" and unticked everything to get a minimum dependency installation (I also tried the full installation, too).

This is an example of an error message which pops up, prematurely ending the *.msi installation (there were / are others, depending on the attempt variations):

err:msi:extract_cabinet_stream FDICopy failed
err:msi:ACTION_InstallFiles Failed to extract cabinet: L"#media1.cab"
err:msi:ITERATE_Actions Execution halted, action L"InstallFiles" returned 1603

Any ideas if there currently is a way to get this thing to work?


For added clarification / distinction:

  • NB: Foxit Reader ( = a pdf reader) is NOT Foxit PhantomPDF ( = a pdf editor).
8
+100

So I followed the links provided by nutty about natty and tested the app using a fresh install using Wine 2.15 (August 20, 2017) with 32 bit (Like the guide I created. Just followed the steps up to the point after running winecfg).

At that point I tried installing the MSI package and the installation went well until at the last window of the installation it told me it failed prematurely and it basically deleted everything that was installed when I clicked on the OK button to finalize the installation.

So what I did was install it again, but instead of clicking on the OK button at the end after the getting the error, I went to the Fox It folder, copied all the content, put it somewhere else and then click on the OK button. After the installer deleted everything again, I overwrote the destination folder with the backup I had created. Then I simply ran the executable and:

enter image description here

Here is me studying AWK again (I suffer from really bad memory so I need to study and repeat things multiple times for them to stick):

enter image description here

Note that this was done without any winetrick apps. Just installing wine, doing the backup once the installer fails and that was basically it. If there is any issues then is probably something additional that was installed. This was tested using Windows 7, but it also worked on Windows 8 and 10.

  • Wow! I could have tinkered around for "years" with dll's and winetricks before just trying your "trick". What made you think that could work? – nutty about natty Aug 20 '17 at 20:48
  • Ok, the bounty is in the oven, ready in 23hrs or so... ;) – nutty about natty Aug 20 '17 at 20:50
  • Sorry for late response. Really sick. Basically I follow a method that starts doing alll installation and testing through the terminal since the gui sucks at telling me what is going on. That also includes checking how an installer works (in this case the way it deleted the files at the end). You tend to think like thay after years of cracking games, apps and just wanting to know how things tick. Am glad the answer helped buddy and like my motto always: think positive! – Luis Alvarado Aug 21 '17 at 16:30
0

Here's a simpler approach: Open the installer, choose custom, and then choose whatever you want except for the Creator option (details of the item reveal that it's the virtual printer). Failure to install the virtual printer will roll back the entire installation. If you choose not to install that feature, then no command line or other tricks are necessary.

The virtual printer part is probably not necessary for most users, since there are many free ones, and their output can then be passed through Phantom PDF.

  • Have you actually tested this yourself (with this installation)? I tried minimal installs and variations thereof but no dice. – nutty about natty Oct 1 '17 at 19:21
  • I tested with PhantomPDF Business 8. Maybe a different version of Wine. Definitely a different distribution. Regardless, it turns out that most of the important features are not working for me: The program alerts that it encounters an internal error when trying to combine files or perform OCR, and it doesn't see my scanner. – M-Pixel Oct 2 '17 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.