1

As the title goes, I can't seem to get pass the login loop issue and need to get my nvidia card working on this machine as it is mandatory for the work it is meant for.

I've tried solutions from (apart from doing a complete fresh ubuntu re-install):-

login infinite loop after installing an Nvidia driver

Graphics issues after/while installing Ubuntu 16.04/16.10 with NVIDIA graphics

The only way to get pass this issue at the moment is to purge nvidia driver and use the default nouveau. But that is less than ideal for my need.

Are there anymore alternative solutions out there? I'm hoping to not have to do a fresh re-installation. And somehow, I have a feeling that it just might not work either.

5
  • Take a look at this question and try steps 13-16
    – itssme
    Commented Jul 13, 2017 at 8:51
  • Is lighdm a typo? Or is it different from lightdm? Because my system already uses lightdm as default Commented Jul 13, 2017 at 8:54
  • Its a typo. If you use ubuntu gnome gdm3 is installed and not lightdm.
    – itssme
    Commented Jul 13, 2017 at 8:57
  • Thanks for the suggestion. It did not work unfortunately. Commented Jul 13, 2017 at 9:10
  • Did you alread take a look at this question? Also you might want to take a look at ~/.xsession-errors
    – itssme
    Commented Jul 13, 2017 at 10:04

1 Answer 1

0

I had the same problem on a Dell XPS 15 9560 with Nvidia GTX 1050 with a fresh install of Ubuntu 16.04.3 tried every possible solution suggestion as linked in you post. Nothink worked.

Finally, I did a fresh install of Linux Mint 18.1, as I wanted to use cinnamon anyway as my main desktop environment (I am using Linux Mint 17 on my previous machine). Interestingly after following normal installation procedure and installing nvidia-375 drivers (via Driver Manager) and rebooting twice (first time for some reason prime-select query indicated an unknown device) everything works as expected including the indicator in the panel and switching between intel and nvidia.

I suspect this is related to Linux Mint 18.1 being build around an older kernel version (4.4.0-89) and the problems could be due to new in the kernel >= 4.8.

So you could check whether trying an older kernel works for you in Ubuntu (for me it did not). Which release of 16.04 did you install?

https://wiki.ubuntu.com/XenialXerus/ReleaseNotes

As Linux Mint 18 is based on the original one Ubuntu 16.04 you could try installing this one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .