5

I have the new Lenovo miix 320 tablet hybrid. I tried to install Ubuntu 17.04 and got a glitch screen with full of lines or black screen. I tried nomodeset but still didn't work.

How do I fix this?

  • I got the same laptop for my wife, and would also like to run some Linux variant on it. So please update if and when you have some progress. – Dov Grobgeld Aug 13 '17 at 17:37
  • Have you tried running your Ubuntu from USB as a live distro? Is all hardware recognized? What is not? – EnzoR Oct 3 '17 at 6:45
3

Ubuntu 18.04 worked. I tried multiple things, so the following list might not be full, but I will update it later after I make a backup.

Warning: Ubuntu 18.04 have not been released yet, so it can be considered unstable. In the meantime daily build is available.

  1. Burn the ubuntu ISO to USB stick (I use unetbootin, crossplatform and works like a charm)
  2. Switch off the secure mode in BIOS (to enter BIOS, hit F2 when the lenovo logo shows up)
  3. Access UEFI boot menu (F12 when lenovo logo shows up) and select the USB stick.
  4. Select Try Ubuntu and hit "E" to edit menuentry. Find the line that starts with "linux" and add "nomodeset" to the end of the line. CTRL-X to continue boot.

The screen rotation may not be correct and the console output does not look readable. But it does boot up. After boot up the screen will be in portrait mode. You can change the screen rotation in "Displays" settings menu. Installing Ubuntu works just fine.

Black screen after boot

After some attempts to boot the screen was black. But after fifth or sixth try it showed the desktop. Later I found out that the system really boots up, just close and open the lid and/or hit some buttons - it will eventually liven up.

Known issues

  • SD card slot is not working (this might be fixed in future updates)
  • Wi-Fi tends to break often. Turned out it's a problem of wifi power management. I managed to find the solution, but don't remember where I've found it. I will update on this later.
  • No battery charge indicator. As a temporary workaround, I noticed that when the battery is low the screen starts flickering.
  • Ubuntu 18.04 is not supported yet and is not stable. – Chai T. Rex Feb 22 '18 at 8:46
  • 2
    @ChaiT.Rex Both observations are of course correct, but I'm voting to let it go anyway because the Lenovo Miix 320 tablet has had so many problems with older releases. – karel Feb 22 '18 at 9:04
  • 3
    @chai-t-rex Yes, 18.04 is not fully supported yet, but it is a matter of time, I suppose. Yet I think it is still worthy to mention that it works, and will probably work better when released. I guess that a downvote is a small price for giving people hope :) But a disclaimer will not hurt I suppose. – viddik13 Feb 22 '18 at 9:16
  • I have made a blog post explaining how to install Ubuntu 18.04 on Lenovo Miix 320 esc.sh/blog/linux-on-lenovo-miix-320 – Root Apr 30 '18 at 17:20
-1

I have the same miix, it’s a problem with UEFI and the internal SSD, BIOS cannot be configurated to AHCI mode (Tales of Lenovo...). So you can boot a live session, install all the firmware and use it with Ubuntu or Debian (I try successfully Debian testing including firmware image and Ubuntu MATE, and it may work whit any distro that use kernel >=4.10), but you cannot install Linux in the internal storage. My next step: try to install Debian in SD card and make something with boot priority, but I don’t know what yet (no options in BIOS...).

Short: You cannot install Linux yet, but you can use Linux from SD card in the meantime before Lenovo fixes the problem.

Long: As I could see in my experience, you will have several problems to configure touchscreen (you can get the graphics on and working, you will have to make an init configuration to get the correct screen orientation, and more to sync your touchs possitions with the mouse possition in the screen, and more if you want autorotation screen and a good configuration of acelerometer), sometimes I had problems with wifi (that tourn off by itself), and I think that it´s not possible to manage the disk (you can mount, umount, read and write, but dont try to resize or make other partitions in internal ssd, you could break all the partition table).

If anyone is thinking about it, I try to resize windows partition to get free space, I made an ext4 partition and I installed Debian in this partiton with debootstrap. It worked, but it´s not possible to install GRUB or LILO (because the kernel cannot get disk information) so I booted with a USB drive and, in the GRUB menu of the USB drive, I used the GRUB command line to boot into Debian. It went fine, but I couldn’t set up graphics.

  • 2
    Try to get to the point and be more specific in your answers. Also note that Debian is not acceptable as answer here on Ask Ubuntu. – derHugo Nov 12 '17 at 19:40
  • Sorry. I was googleing a lot and you can try this: boot the usb drive, edit grub menuentry install ubuntu and add at top "set gfxpayload=keep" and "set gfxmode=800x1280" after you must add to linux cmdline "nomoset i915.modeset=1 fbcon=rotate:1". It worked in my miix 320 – PJR Dec 17 '17 at 18:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.