0

I am on ubuntu mate 17.04. When i do

sudo apt-get upgrade

and then restart my computer, i get dropped to the busybox prompt. Then i do theses two steps

dumpe2fs /dev/sda5 | grep superblock
fsck -b 32768 /dev/sda5 -y

and then again restart the computer. It resumes normally. But every time i upgrade my machine same story. i have nvidia drivers installed. What is going wrong? Is there a solution other than not upgrading my machine?

  • 1
    Do you dual-boot with Windows? If so, have you installed a driver there that allows you to read/write to Ubuntu EXT4 partitions? – heynnema Jul 12 '17 at 22:04
  • Yes i dual boot with windows 10. I installed DiskInternals-Linux-Reader software in windows to access Linux files from windows. – user_1_1_1 Jul 13 '17 at 18:26
  • I have also installed EasyBCD and EaseUS PM in windows 10. – user_1_1_1 Jul 13 '17 at 19:32
0

From the comments...

re: Do you dual-boot with Windows? If so, have you installed a driver there that allows you to read/write to Ubuntu EXT4 partitions?

If DiskInternals-Linux-Reader software is like other similar Windows drivers, the result is the same... corrupted Ubuntu file systems.

Uninstall DiskInternals-Linux-Reader software, and fsck your Ubuntu partition once again, and I suspect that your problem will be solved.

If you really wish to share files between Windows and Ubuntu, create a new NTFS partition on your disk, and both can read/write to it.

  • I uninstalled that software and fscked but when i upgraded the boot initrafms must have been reset as i again got dropped to busybox prompt and had to recover using the two steps mentioned above. Is the distro at fault? Because i uninstalled nvidia drivers also. And i have worked with other linux distros and never come across this problem. – user_1_1_1 Jul 14 '17 at 19:30
  • I assume that you're doing fsck at the Additional Options/Root Access GRUB menu, yes? What happens if you just fsck -f / or fsck -f /dev/sda5... do you get a superblock error? Lets try and create a new initramfs for you... boot up fully, and in terminal do sudo update-initramfs -c -k "$(uname -r)", then reboot. – heynnema Jul 14 '17 at 20:10
  • @user_1_1_1 ps: do you have a SSD? – heynnema Jul 14 '17 at 20:16
  • I am doing fsck at busybox prompt only: fsck -b 32768 /dev/sda5 -y. Let me try your suggestions and get back to you. – user_1_1_1 Jul 14 '17 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.