6

I ask the same question a couple of weeks ago but the question was closed because it was related to Ubuntu 17.10 which is under development.

However, I have the same (and worse) issues for the LTS 16.04 and for the new Ubuntu 17.04 or 17.10. Therefore I am asking this question again and because other people also report similar behaviour I wanted to discuss this issue in details.

First you can find the NEW POST and below the INITIAL POST. Please note that the NEW POST mostly refer to the INITIAL POST and that there has be four EDITS on the INITIAL POST.

EDIT 1: providing a part of the system and temperatur sensor logs EDIT 2: name confusion between Gnome and Unity EDIT 3: Installation of Centos 7 which still shows screen flickering but no shutdowns. EDIT 4: Installation of Centos 6 after an uncarefully made update under Centos 7 triggered random shutdowns again.


The following posts contain similar behavior as I am experiencing, often a Lenovo or a Dell computer are involved:

Flickering screen with Intel graphics on Ubuntu 17.04 --> for me the same if I am using and external screen or the laptop

weird screen flickering issue in ubuntu 17.04 GNOME --> I tried everything which is mentioned here

There are many people who having the similar problems. I wanted to include links to their posts but I am lacking reputation in order to do that, sorry for that.


The device:

  • Lenovo Thinkpad T410
  • Intel® Core™ i5 CPU M 540 @ 2.53GHz × 4
  • Intel® Ironlake Mobile 64Bit

The problem:

Same as reported before (see below) but issues went worse:

  • Now random shutdowns when especially using shell every couple of minutes
  • When using other programs less, but screen flickering often experienced when typing
  • Shell (especially when connected via ssh to a server) is frozen in after a couples of minutes
  • flickering looks like that: https://www.youtube.com/watch?v=TqAljJ0U5Pc

The attempts to fix the problem

NEW POST:

Note that this time I did not install any additional driver or manipulated the software or tried to following instructions for other posts. I just set up the system and tested it. In the INITIAL POST it is described what I tried to do to fix the problems before, but nothing worked out so far (it just went worse). Also installing the latest version of Intel driver did not help. The screen flickering appeared after using the computer half an hour, first random shutdown after 2 hours.

INITIAL POST (an overview details below):

  • installing latest Intel driver for Linux
  • reinstalling Ubuntu 17.04, updating to 17.10, reinstalling 16.04 (apparently nothing worked out!)
  • checking if this is a heat related problem, but the senors does not show any overheating
  • following instructions from other posts describing similar problems
  • switching from Unity to Gnome

Further observations:

Screen flickering or shutdown does not appear e.g. when I am typing inside the Chrome Browser or writing an email!


NEW POST (relating to Ubuntu Unity LTS 16.04)

The software:

  • Ubuntu LTS 16.04 64 Bit
  • unity 7.4.0

INITIAL POST (relating to Ubuntu Unity 17.04/17.10)

TIME STAMP: 16:00

I am experiencing some graphic failure, screen flickering and random shutdowns from Ubuntu 17.10 on my Lenovo Computer (although System settings-->Details show 17.04!). I appreciate very much your help!

The software:

  • Ubuntu 17.10 64 Bit (Zesty Zapus)
  • unity 7.5.0

The problem:

  • Screen is starting flickering randomly: anytime I press a key, 1 flicker.
  • This goes on for several times and then the screen turns black only showing one red blinking line on the left side. After about 30s doing that the laptop shuts down.
  • The shutdown happens randomly but correlates with screen flickering, the more flicker we had before the often the laptop shuts down a flicker happens usually when typing into the shell usual keys are: backspace, enter, up/down key, first key pressed if typing something into the shell
  • I also experienced it when typing into the search bar of Ubuntu
  • SoftwareDrivers for the graphics not listed inSystem Settings--> Software & Updates --> Additional Drivers` does not recognize any installed graphic drivers
  • Behavior is similar to the issues reported by Aqil Hex and many more (not allowed to post more links here -- sorry!)

How I tried to solve it:

  • Updated and reinstalled Ubuntu and other graphic related packages many times.
  • Installing the latest drivers from Intel Graphics for Linux web page v2.0.5.

This is the current configuration:

System:    Host:    serenity Kernel: 4.10.0-22-generic x86_64 (64 bit)   
             Desktop: Gnome 3.24.2
             Distro: Ubuntu Artful Aardvark (development branch)
  Machine:   Device: laptop System: LENOVO product: 2537E82 v: ThinkPad T410
             Mobo: LENOVO model: 2537E82 BIOS: LENOVO v: 6IET85WW (1.45 ) date: 02/14/2013
  CPU:       Dual core Intel Core i5 M 540 (-HT-MCP-) speed/max: 1199/2534 MHz
  Graphics:  Card: Intel Core Processor Integrated Graphics Controller
             Display Server: X.Org 1.19.3 drivers: modesetting (unloaded: fbdev,vesa)
             Resolution: 1366x768@59.79hz
  GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 17.1.2
  Network:   Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e
             Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi
  Drives:    HDD Total Size: 128.0GB (62.0% used)
  Info:      Processes: 232 Uptime: 3:40 Memory: 2760.0/5761.8MB 
             Client: Shell (bash) inxi: 2.3.11 
Verified my installation following this steps from AMD Linux Community.

  glxinfo | grep direct
  direct rendering: Yes

I want to follow the configuration for Ubuntu 17.10 posted on this page and that from the offical documentation page: https://help.ubuntu.com/community/BinaryDriverHowto/AMD but currently I am not sure if I should do that (I do not want to make it worse)... I also have the problem that fglx and ati are not used for Ubuntu 17.10.

Further observations:

My laptop is connected to a screen Acer 19" Screen (resolution: 1366x768) and I am using an USB keyboard. However, if am using the laptop alone I am experiencing the same issues but less often.

EDIT 1

TIME STAMP: 18:00

After heynnma mentioned that I could have a heat-related problem I tried to install a monitoring software and followed the SensorInstallHowto installation manual on the Ubuntu page.

I do not think that my Problem is heat related, since the fan stays nice and quiet and the laptop does not physically show heat. There have been no critical temp warning in my syslog, I only found something like this:

Jun 16 17:22:17 serenity sensors[590]: acpitz-virtual-0
Jun 16 17:22:17 serenity sensors[590]: Adapter: Virtual device
Jun 16 17:22:17 serenity sensors[590]: temp1:        +48.0°C  (crit = +100.0°C)
Jun 16 17:22:17 serenity sensors[590]: thinkpad-isa-0000
Jun 16 17:22:17 serenity sensors[590]: Adapter: ISA adapter
Jun 16 17:22:17 serenity sensors[590]: fan1:        3906 RPM
Jun 16 17:22:17 serenity sensors[590]: temp1:            N/A
Jun 16 17:22:17 serenity sensors[590]: temp2:         +0.0°C
etc ...
Jun 16 17:22:17 serenity sensors[590]: temp8:         +0.0°C

While running sudo sensors-detect and choosing YES to all YES/no questions. The system crashed again. Here are the mos suspious lines of my syslog (I uploaded more of it to my Dropbox ready to download --> syslog on Dropbox

 Jun 16 17:19:42 serenity gnome-terminal-[1829]: Allocating size to GtkBox 0x5570bdd0fb60 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
 Jun 16 17:19:43 serenity gnome-terminal-[1829]: message repeated 11 times: [ Allocating size to GtkBox 0x5570bdd0fb60 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?]
Jun 16 17:20:14 serenity kernel: [22014.721331] i801_smbus 0000:00:1f.3: SMBus using PCI interrupt
\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00
\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00
\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00
\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00Jun 16 17:22:17 serenity rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="577" x-info="http://www.rsyslog.com"] start
Jun 16 17:22:17 serenity rsyslogd: rsyslogd's groupid changed to 108
Jun 16 17:22:17 serenity rsyslogd: rsyslogd's userid changed to 104
Jun 16 17:22:17 serenity rsyslogd-2039: Could not open output pipe '/dev/xconsole':: No such file or directory [v8.16.0 try http://www.rsyslog.com/e/2039 ]
Jun 16 17:22:17 serenity rsyslogd-2007: action 'action 11' suspended, next retry is Fri Jun 16 17:22:47 2017 [v8.16.0 try ...
The shutdown happened exactly when I hit the ENTER key with:

 /etc/init.d/kmod start

Could anyone please take a look on it and maybe see whats wrong with my system? Thanks a lot!

EDIT 2

There was a confusion between Unity and Gnome! The software manager also did not work properly and after trying to install updates again and restarting the computer many times, my system was finally showing GNOME as desktop environment. However, I had the same issues and behaviour as reported before.

EDIT 3

August 2017

I got rid of Ubuntu and installed Centos 7 because I heard that Centos kernels are not so heavy than the Ubuntu ones. So Ubuntu's kernel are so-to-say-full with all kind of stuff which might not be compatible with my hardware where Centos might not have them included. It worked and I still have flickering all the time but no shutdowns.

EDIT 4

10/26/2017

I still used Centos 7 but after doing an update of the system uncarfully (I wanted to install gcc libraries and updated the kernel). I crashed the system again. I had the same issues: flickering and random shutdowns (with very little time between them!).

I noticed that with that update I also installed another kernel on my computer which might trigger the shutdowns (but I am not sure!). I could not redo the update and had to set up the system again.

My solution to the problem was to go even further back and I installed Centos 6 and will not do any fancy updates any more but I still looking for a solution and want to understand what happening to my computer and how I can prevent it.

  • I had the same problem with flickering as you describe after updating KUBUNTUfrom 17.04 to 17.10 (I have a dual graphics AMD/intel but use the intel). Changing the rendering backend from OpenGL to Xrender removed the flickering, though I guess the performance will not be the same. – Bruni Oct 20 '17 at 15:07
0

One workable (but perhaps not the) solution to the screen tearing issue on 17.04 and 17.10 using a Lenovo (mine is a Yoga 910 with KabyLake) is to add i915.enable_rc6=0 to your boot parameter. See this ArchLinux post.

This works, but as I will note in a separate post, it disables some critical power management functions. Specifically, it "will cause the CPU/GPU to remain in high-power modes." As a result, the fan stays on high constantly. Specifically, it "will cause the CPU/GPU to remain in high-power modes." This to me makes it unusable.

I tried a number of other solutions, including:

  1. Installing Intel Graphics Update Tool for Linux (this seemed to work for 17.04, but there is no updated tool for 17.10 until October 2017)
  2. Installing Intel Firmware drivers manually from https://01.org/linuxgraphics/downloads/firmware
  3. Adding 20-intel.conf to /usr/share/X11/xorg.conf.d and adding this:

    Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "sna" Option "TearFree" "true" EndSection

I have not confirmed this, but I suspect the issue is with the kernel rather than the operating system. It appears that the kernels above 4.4 that come with the upgraded systems have the issue. In all events, the power management issues should be solvable by either the kernel team or the OS team.

  • Thanks for your answer. I would also not take the risk of messing with the power system, so I will not enable that. You are right it is rather the kernel than the operating system. I am running CentOS 7 now, I still have the screen flickering but no random shutdowns, which kind of solved my problem. – firefly2517 Aug 4 '17 at 12:27
  • Hello again, I can totally confirm that issue. I updated without knowing from a lower version on a newer kernel version (however for Centos, not for Ubuntu!) -- Please see EDIT 3 and 4 – firefly2517 Oct 26 '17 at 16:13
0

Please, keep this thread running, since I have exactly the same problem with my T410s. So far no solution, but I can not even use the system, the screen is more black than showing content.

Thanks for any help!

Edit: Compare I upgraded from kubuntu 14.04 LTS to 16.04 LTS and now my screen shows up and disappears There I had posted originally, and the interesting part may be, that I have two identical machines, on the same docks, and my other machine does not show this behaviour at all. Since you seem to be pretty good in this, I will be glad to help out in finding out the difference in these two machines that actually make the difference. Same BIOS version. Same level of upgrade (kubuntu backports on 16.04).

  • Hello, thanks for answering! I will keep it open, I was trying Centos 7 and 6 which made a big different regarding the problems. However, I still cannot install any fancy software or any newer kernel could crash my system (this is at least what I am observed, but I am not sure what really causes the problem!). – firefly2517 Oct 26 '17 at 16:11
0

You might try setting up an xorg configuration file and setting the AccelMethod to "uxa". I have just had this problem with ubuntu 16.04 on a T410. I had the problem previously on a T400 in OpenSUSE (pre leap 41.2). As far as I remember OpenSUSE leap handled the problem by providing this configuration.

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

From what I am reading Ubuntu is relying on automatic configuration, but that fails for the old hardware we are working with.

  • Hello, thanks for answering! I will try it out! – firefly2517 Oct 26 '17 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.