0

I was unable to install the Nvidea GTX1050t driver on my Ubuntu 16.04 machine, by following Nvidia's "instructions".

I would appreciate any advice and help resolving this issue.

Thanks

2

You can install nvidia drivers via apt.

Fist remove all not working drivers

sudo apt-get purge nvidia-*

Then add the repository for the drivers

sudo add-apt-repository ppa:graphics-drivers/ppa

Then update

sudo apt-get update

Then install the actual drivers

sudo apt-get install nvidia-384

After that reboot.

I had problem with gdm3 so if the drivers still do not work and you are getting a black screen try installing lightdm.

3
  • You can install even newer versions.
    – user692175
    Jul 12 '17 at 9:34
  • I tried everything suggested here, got as far as sudo apt-get install nvidia-375 when everything swithced off as it was displaying something to the effect of Building initial package for 4.8.0-36-generic. After rebooting, I would type in my login password, only to have the screen blip out and take me right back to the login screen. The only recourse I knew was to re-install Ubuntu at this point. I've installed lightdm as suggested an am going to try again.
    – ponhawk
    Jul 13 '17 at 21:53
  • I tried it, system shut off and locked me out of Ubuntu again. This time I got a better look at the offending operation: Building initial module for 4.8.0-58-generic I Re-installed Ubuntu from the bios for the fifth time. tried using the Software & Updates tool to install it instead, same thing happened. Re-installed Ubuntu again. Hmmm... Maybe I should try a newer version of the driver, as Michael Bay suggested?
    – ponhawk
    Jul 14 '17 at 0:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.